Diagnostic-Code: smtp; 550 smtp auth required - Details are correct

Happy new year!

I have encountered a problem of which i’m not sure where to look for the solution: an email, - sent through a SMTP plugin in Wordpress (with Contact Form 7) - is successfully being sent to the recipient -but- the copy to itself ([email protected]) holds the following error:

This is the mail system at host outbound5.mail.transip.nl.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<[[email protected]](mailto:[email protected])>: host mail.my-client.nl[my-vps-ip] said: 550 smtp
auth required (in reply to RCPT TO command)

Reporting-MTA: dns; outbound5.mail.transip.nl
X-Postfix-Queue-ID: 4Nm8rz1JfyzHQrp
X-Postfix-Sender: rfc822; [[email protected]](mailto:[email protected])
Arrival-Date: Mon, 2 Jan 2023 22:58:59 +0100 (CET)

Final-Recipient: rfc822; [[email protected]](mailto:[email protected])
Original-Recipient: rfc822;[[email protected]](mailto:[email protected])
Action: failed
Status: 5.0.0
Remote-MTA: dns; mail.my-client.nl
Diagnostic-Code: smtp; 550 smtp auth required

Is this something within HestiaCP not sending the auth details? I’m sure that those are correctly setup in the SMTP plugin.

If I take a look at the exim mainlog it shows:

2023-01-02 22:43:50 H=outbound0.mail.transip.nl [14X.XXX.XXX.69] X=TLS1.2:ECDHE_X25519__RSA_SHA512__AES_256_GCM:256 CV=no F=<[email protected]> rejected RCPT <[email protected]>: smtp auth required
2023-01-02 22:43:51 1pCSb1-007xjk-0m <= <> H=outbound0.mail.transip.nl [14X.XXX.XXX.69] P=esmtps X=TLS1.2:ECDHE_X25519__RSA_SHA512__AES_256_GCM:256 CV=no S=5562 [email protected]
2023-01-02 22:43:51 1pCSb1-007xjk-0m => info <[email protected]> R=localuser T=dovecot_virtual_delivery
2023-01-02 22:43:51 1pCSb1-007xjk-0m Completed

Thanks in advance!

If the mailbox [email protected] is hosted on the receiving exim, exim does not allow incoming mail with [email protected] set as the sender without proving (auth required) that the sender is [email protected]

Set the sender to something else.

2 Likes

Thanks a lot @maurice for pointing me in the right direction!
Solution was to change the sending email address within my wordpress to [email protected] -ánd- also changing the SMTP settings within wordpress from using my VPS’s smtp relay settings to just use the info of [email protected] / mail.my-client.nl. I still keep my VPS’s smtp relay in HestiaCP’s relay settings of course.
Thanks again!

2 Likes