Disable open_basedir Hestia 1.3.2

Hi -

I’m trying to disable open_basedir by editing/commenting php_admin_value[open_basedir] = line in /usr/local/hestia/data/templates/web/php-fpm/[PHP-Version].tpl without success in Hestia 1.3.2. version.

Can you please help me with this?

Regards,

Replace:

php_admin_value[open_basedir] = /home/%user%/web/%domain%/public_html:/home/%user%/web/%domain%/public_shtml:/home/%user%/tmp:/var/www/html:/etc/phpmyadmin:/var/lib/phpmyadmin:/etc/phppgadmin:/etc/roundcube:/var/lib/roundcube:/tmp:/bin:/usr/bin:/usr/local/bin:/usr/share:/opt

With

php_admin_value[open_basedir] = /

Please not I am not responsible for any issues

If you are smart you make an custom template as default templates will get overwritten by default

1 Like

Thanks Eris -

It does the job.

Regards,

Hello guys. I with the same problem. I configure a new VPS with New Directadmin and New Centos. Going to put the Laraclassified script. And the site shows the message:

" ERROR: Please disable the open_basedir setting to continue."

And finding the [open_basedir] expression in files, i locate the file:

/usr/local/directadmin/data/users/admin/php/php_fpm74.conf

And change like you did. I change
php_admin_value[open_basedir] = |OPEN_BASEDIR_PATH|
to
php_admin_value[open_basedir] = /

And i execute the command:
cd /usr/local/directadmin/custombuild
././build rewrite_confs

in my phpinfo() the path desapear, going to:
open_basedir /

But famigerated message: " ERROR: Please disable the open_basedir setting to continue." continue.

Please any help me!!!
Regards,

Daniel Cesar

Please contact Directadmin support

2 Likes