DNS / domains not loading


Running Hestia ver 1.1.1 on ubuntu 18.04

Just realized the i can’t get the domains to load.

I did added one domain before 1.1.1 and is running fine, today i tried another 3 domains but no luck at all please see attached config for the domain.

Would appreciate some help on this.


Adding SSL Error

did you set the authoritive NS server entries with your domain provider to the IP of your hestia server?

i have it pointing to Cloudflare by the pas year and now (few hours) changed in CF to point to the hestia cp ip

so you are using cloudflares dns servers or the A entry for your domain points to cloudflare?

to be clear: first, with your domain registrar you need to setup which nameservers you use, so that a resolution can happen at all. if you use cloudflares dns servers, then any changes/ns entries have to happen there and anything in Hestia DNS does not matter.
if you want to use your server/hestia for DNS, then that IP has to be set in your domain registrars interface…

This domain i own it for years and is on Cloudflare for years, on vesta all i was doing was changeing the ip in CF where i want the domain to point.

Till today it was on a vestacp vps, then today after i adjusted the ip setting in CF i tryed to add this on hestia, but to my surprise is not working, can’t access it.

alright, as said above, if dns is handled on cloudflare then all the dns settings from hestia that you posted above don’t matter for the real dns resolution as only the cloudflare dns server are allowed and answering any dns requests.

you might have messed something up inside that config anyway, while trying to fix things there that aren’t broken. I suggest to remove that domain completly from hestia and start fresh by adding it new.

on top letsencrypt might still not work, if you have whatever sub- or alias domain in there, which is not correctly configured in cloudflare dns then.

I’m lucky that is Sunday :slight_smile: and this is a test vps.

Destroyed the droplet and will reinstall, still can’t get it what went wrong as the domain existed on CF for long time and i deleted the user in hestia and the domain but did not helped.

Will update in a while as soon i have it up

also I suggest to check that the domain really resolves to your servers IP f.i. with dig. rest asured, this is no Hestia related issue, but something might be off with your whole DNS setup.
I guess you are either missing entries in cloudflare or the changes from old to new are not even yet populated.

1 Like

i Think i might found out why all this.

this relate with the fact that my test hestia cp was under a brute force attack, might been successful, as it got 1 domain in spamhouse, i destroyed the the droplet installed the hestia and the old domain worked not the one blocked on smpamhouse.

Seems you’ve got some issues to handle out, even when you got brute force attacks, dns should always work. As @falzo already wrote, this arent any issues with hestia itself. I would suggest to fix the dns issue first, you can also use cloudflare instead hestia dns stack - we do this even for hestiacp.com.

My panel hostnames with custom ports don’t work using CF proxy, do work with DNS only.