DNS is not updated

После последнего обновления 1.4.10 не обновляются DNS.
Как это исправить?

DNS is not updated after the last update.
How to fix it?

Please explain?

Мне нужно было добавить 2 под домена (олд, тест), я добавил. ДНС сервер не видит новые под домены. Я решил попробовать удалить другие (поп, маил) чтобы проверить, но ДНС сервер все ровно не обновляет. На ДНС сервере при нажатии обновить информацию о доменах, он получает список тот который был раньше.

Есть где-то файл в hestiacp где указан этот список доменов и под доменов которые отправляются на ДНС сервер?

I needed to add 2 under the domain (old, test), I added. DNS server does not see new domains. I decided to try deleting others (pop, mail) to check, but the DNS server does not update everything exactly. On the DNS server, when you click to update information about domains, it receives a list of the one that was before.

Is there a file somewhere in hestiacp where this list of domains is indicated and under domains that are sent to the DNS server?

You are using the Hestia DNS cluster ?

No, bind9

Please explain at least the basic of your setup. Unless zone_transfer has been enabled with in Bind config Hestia does not support zone transfer between 2 bind servers.

On your “Hestia” server you can list the domain via
v-list-dns-domains user or check /etc/bind/named.conf

Via nsloopup domain.com

[email protected]:/etc/bind# nslookup xxx.nu
Server: 127.0.0.53
Address: 127.0.0.53#53
Non-authoritative answer:
Name: xxx.nu
Address: x.x.x.x

I manually added to /etc/bind/named.conf

If you dont use hestia as your nameserver, which needs a hestia dns cluster, you need to setup the records at your name server provider like cloudflare, domain registrar etc.

Before that it was updated (2 years) and in 1.4.10 it is not updated

The technical support wrote
The server does not respond to DNS requests

;; connection timed out; trying next origin
;; connection timed out; no servers could be reached

HestiaCP records (subdomains) are not disabled in the DNS, I try to disable them, but they are of the active type, I cannot see that they are disabled.

I don’t know how you setup your dns server. Usualy you setup hestia with a dns cluster, if you want to setup the dns on your own. Also 1.4.10 hadnt any changes on the dns stack itself, last changes where releases ago.

Can you be a bit more specific what you’re using, in which setup and also maybe check your bind log (in case of a hestia dns cluster)?

I figured it out, bind chose a different default-nomail template and everything worked

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.