DNS problem with godaddy

Hi my new friends, I read in the forum and did everything necessary, but I still have a problem. The situation is as follows: I have two domains and one vps server. for this purpose, one domain is registered only to serve as a dns network.

DevDNScom
DevDomain
com

In Goddady for DevDomain. I used this dns name:
ns1.devdnscom
ns2.devdns
com

In HestiaCp I add devdomain.

In Godaddy for DevDns. my settings is this:

And I no problem for opening devdnscom
, Bu i have a problem for opening devdomain
.com

How I can solved this problem

I read this
forum.hestiacp*com/dns-dkim-questions-pre-install-prep/2658/2

I think I did, but my domain still doesn’t open. my idea is to have one domain for dns and then add multiple domains using dns

P.S. The two-link limit sucks because I haven’t been able to post my topic for 1 hour

remove the last 2 NS records otherwise It will still link to those

In godaddy or in HestiaCp

In Go daddy

No, no working after change.

This is for DevDNS.COM

This is for DevDomain.com

I think I’ve done similar things, though; let me see if I understand.

You have:

  • dnsmanage.tld
  • domain.tld
  • You want to delegate the zone management of domain.tld to dnsmanage.tld

If this is the case, you must do the following:

  • For dnsmanage.tld: Create glue records pointing to the HestiaCP IP, for example; ns1.dnsmanage.tld and ns2.dnsmanage.tld (although the captures are outdated the process works Create Glue Records at GoDaddy | Register Nameserver - Interserver Tips).

  • For domain.tld: Delegate DNS management to the above Glue Rercods (ns1.dnsmanage.tld and ns2.dnsmanage.tld). Note: I saw in one of your messages that you already did something similar with dnsmanage.tld but that way it doesn’t work because it ends in a kind of circularity that doesn’t point to anything.

Translated with www.DeepL.com/Translator (free version)

===========Por si entiende español, que es el lenguaje en que escribí===============

Creo que he hecho cosas similares, sin embargo; déjeme ver si entiendo.

Tiene:

  • dnsmanage.tld
  • domain.tld
  • Desea delegar el manejo de la zona de domain.tld a dnsmanage.tld

Si este es el caso, debe hacer lo siguiente:

  • Para dnsmanage.tld: Cree glue records que apunten a la IP de HestiaCP, por ejemplo; ns1.dnsmanage.tld y ns2.dnsmanage.tld (aunque las capturas son anticuadas el proceso funciona Create Glue Records at GoDaddy | Register Nameserver - Interserver Tips).

  • Para domain.tld: Delegue la gestiĂłn de los DNS a los Glue Rercods anteriores (ns1.dnsmanage.tld y ns2.dnsmanage.tld). Nota: Vi en uno de sus mensajes que ya hizo algo similiar con dnsmanage.tld pero de esa manera no funciona porque termina en una especie de circularidad que no apunta a nada.

3 Likes

I did that too, but to no avail. You got me right. When I test the domain with dnschecker, it turns out that no dns for the domain were found (but they are set correctly in the Godaddy panel)

That is ambiguous because godaddy has both:

  • Settings under domain
  • Settings under DNS (not to be used if you are going to use hestiacp as DNS server)

Both of them have to be correctly set up.

Please follow this guide and you will have everything correct.

1 Like

It is extremely strange to me that it works under the domain webmail.domain.tld, but the main site does not open.

This is settings in Goddadt for DomanDNS.tld As you can see, here I have two NS servers (ns33.domaincontrolcom) that are added by GoDaddy and I do not have the right to edit them. For this I specify the IP Address of the server and create Host names (application photo)

This is settings in HestiaCP for DomanDNS.tld
https://forum.hestiacp.com/uploads/default/original/2X/2/2ed6856f6f50b217861f2bdffa3985b30f9ac936.png

This is settings in HestiaCP for Doman.tld
https://forum.hestiacp.com/uploads/default/original/2X/9/930246ca28f5f36a8274ad722e1507e9f4c87b39.png

I checking in dnschecker*org/all-dns-records-of-domain.php

Domain.tld and I have this result:
Cannot fetch Authoritative NS of Domain.
It seems to me that everything was done correctly, but there is no right result. Please someone give me a step by step answer, which to correct (I add photos for convenience for my settings)

[email protected]:~# nslookup devdomaindns.com
Server:         212.227.123.16
Address:        212.227.123.16#53

Non-authoritative answer:
Name:   devdomaindns.com
Address: 77.68.**.**

[email protected]:~# nslookup devdomain.com
;; Got SERVFAIL reply from 212.227.123.16, trying next server
Server:         212.227.123.17
Address:        212.227.123.17#53

** server can't find devdomain.com: SERVFAIL

[email protected]:~#
[email protected]:~# cat cat /home/domainuser/conf/dns/devdomain.com.db
cat: cat: No such file or directory
$TTL 14400
@    IN    SOA    ns1.domaindns.com.    root.devdomain.com. (
                                            2021082705
                                            7200
                                            3600
                                            1209600
                                            180 )

@       14400   IN      NS              ns1.domaindns.com.
@       14400   IN      NS              ns2.domaindns.com.
@       14400   IN      A               77.68.**.***
www     14400   IN      A               77.68.**.***
ftp     14400   IN      A               77.68.**.***
mail    14400   IN      A               77.68.**.***
smtp    14400   IN      A               77.68.**.***
pop     14400   IN      A               77.68.**.***
imap    14400   IN      A               77.68.**.***
@       14400   IN      MX      0       mail.devdomain.com.
@       14400   IN      TXT             "v=spf1 a mx ip4:77.68.**.*** -all"
_dmarc  14400   IN      TXT             "v=DMARC1; p=quarantine; pct=100"
_domainkey      14400   IN      TXT             "t=y; o=~;"
mail._domainkey 14400   IN      TXT             "v=DKIM1; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDHONVJMEoRad+fuHDXHPhWmRDzEcFnnq7tR77Kou9T8ha0el2amtKdjGxnnXoUvOE0d4SNfDxJctiJ/Y/Pu4TZhWelSnDF6PeLK2SXJlls/cyWG0HYYvuKQsJ0zqchJHHY32FHTUJc8rYHo8qQKKUDKLquORav/yPITtB0sz049QIDAQAB"
webmail 14400   IN      A               77.68.**.***
[email protected]:~#

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.