DNSSEC view public key

Although DNSSEC is present, “View Public DNSSEC Key” is missing.
HestiaCp v1.7.1, Debian 11.6. I have no idea where to look and what to check! Can you guide me, help me with this?
Thanks to the Hestia team, you are doing a great job.

Solved. DNS clusters and DNSSEC | Hestia Control Panel
DNSSEC can’t be used when Hestia Cluster is active as Master ↔ Master

Converting an existing DNS cluster to Master → Slave

  1. In /usr/local/hestia/conf/hestia.conf, change DNS_CLUSTER_SYSTEM='hestia' to DNS_CLUSTER_SYSTEM='hestia-zone'.

Although I solved one minor thing, I run into another. The Bind version told me that DNSSEC is not compatible with 1.18, I checked the version in the installed vm and it is 1.16. Someone help me understand. I installed the machine 2 times and the result was the same.

Version is 9.16 and it in smaller then 9.18 …

So it isn’t supported…

Only 9.18 (Debian 11 or Ubuntu 22.04) are working fine…

1 Like

Hestia runs in vm, proxmox, Debian 11.6 bullseye. Could I solve it somehow?

Please update following files

1 Like

It works fine in Ubuntu, not in Debian. Regardless of which version of Debian I install, 11.1, 11.6, bind 1.16 comes installed by default.

I know version check is wrong see the changes in the PR I have made

1 Like

You can install BIND 9.18 from backports.


version=$(named -v | awk ‘NR==1{print $2}’)
if version_ge ‘9.18’ $version; then
check_result “$E_DISABLED” “DNSSEC is not supported when bind / named < 9.18”
check_result “$E_DISABLED” “DNSSEC is not supported when bind / named version <= 9.16.18”

It worked with a little modification. I also changed this if version_ge ‘9.16’ $version; then.
Thank you @eris . Today I learned something else. I appreciate your patience.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.