Error: DNS record for <domain> doesn't exist

I have tried all possible and imaginary settings.
I’ve used name servers from different vendors.
Every time I try to activate an SSL certificate the error appears and I can’t use Lets Encrypt certificates.
We are going in 3 days on this …
I’m sorry, but it’s too problematic to use in production!

1 Like

This isnt a hestia issue, it’s a local dns one. Hestia has a validation check before send the request to let’s encrypt. Your server will trigger a nslookup domain.tld, if there is no record, it will stop with the error message above.

So probaly do it manualy and verify, why your server doesnt get a propper dns reply. Also you can verify your record using

All DNS are all ok
I have done nothing but check the DNS

Do you want to bet that I do an installation with CWP Control and everything works?

This problem is recurrent with other users from what I see in other posts here on the forum.
I value your work, but I believe that this problem should be looked at more carefully.
I really like HestiaCP, but this detail is fatal.
On another server with .eu domains (Europe) it was an adventure, suddenly after two days of trying, it started to work without understanding why.
Maybe the problem is in the geolocation of the servers, maybe the local time, I don’t know …
I will report with the use of another panel, although I am experimenting with CWP, I would prefer to use HestiaCP.
NOTE: The server in question is located in Germany (Hetzener)

Once again, this isnt a hestia issue. As explained above, this is resulting your problem:

And you can’t compare that one with CWP or any other control panel, it’s just a validation check which I’m not sure if anyone else have it.

So: Check nslookup domain.tld from your server and you’ll see, that you got a dns issue on your server - that’s all.

Sorry for my mood
There are many days trying to solve a problem that would be simple in the beginning.

The problem is with the settings that the dedicated server vendor applies by default.

nano /etc/resolv.conf
nameserver 2001: 4860: 4860 :: 8888
nameserver 2001: 4860: 4860 :: 8844

…and this is it

Thank you so much for your time

1 Like

As I said, have fun using hestia in productive :grin:.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.