Error: hestia update failed

Hello everybody!

  1. Found in the spam folder on gmail -
    Cron <admin @ bostic> sudo / usr / local / hestia / bin / v-update-sys-hestia-all
    With content:
    Error: hestia update failed
    Error: hestia-nginx update failed
    Error: hestia-php update failed
    What is the reason and how to solve it?
  2. Why do letters get into spam?
    Hestia 1.1.0 Debian 9

Thanks!

Hi

For Nr. 1, checkout the changed gpg key: Hestia 1.1.0 released!

For Nr. 2, this depends on IP Reputation and a few other parts, basicly it is not easy to answer.

1 Like

You may want to start with https://www.mail-tester.com/ and/or http://www.allaboutspam.com/email-server-test/ which will give you some hints about what’s wrong.

2 Likes

Thanks Felix :+1:I will read

Hi @bostic,

For mail, you’ll want to ensure that all of your DNS, DKIM, DMARC, and SPF records are configured correctly and it’s highly recommended to enable SSL for the mail domain for additional security.

In terms of deliverability, some providers such as Microsoft, Google, and Yahoo for example have fairly strict filtering policies, and the IP address ranges that are leased out to VPS or dedicated server owners are considered “low reputation” as they are frequently reassigned and in general have seen past abuse.

Until you’ve built up a reputation of known good mail (where users are marking your email as not junk, not reporting them, etc) your messages will most likely wind up being picked up by spam filtering. The tools that @Felix linked above should indicate if your IPs have been placed on any blacklists.

1 Like

I can confirm No. 1 is not due to gpg key, I’m receiving these emails continusly since I’ve installed HestiaCP, these were present in V1.0.6 and these are also present in V1.1.0. I’ve new update gpg key on my server.
No. 2 in most of cases is because people forget to add SPF, DKIM and DMARC for the “hostname” of their server.

Just checked on my system, running 1.1.0 with current gpg key and can’t reproduce the issue.

What happens when you run v-update-sys-hestia-all manually? It looks like you still havent installed the gpg key, because the upgrade procedure, hestia-nginx and hestia-php package hasnt been changed. The only thing changed was the gpg key.

I’m facing this issue from last year since Installation. Just after the release of V1.1.0 I updated my gpg key and ran apt-get update && apt-get install --reinstall hestia because I was on beta and this command reinstalled the HestiaCP successfully which I think means gpg was added correctly.
Just to be sure I’ve tried re-adding gpg key and running v-update-sys-hestia-all manually, but it yielded same result.

This is quiet an important information :slight_smile:… So it is not related to the gpg key change and seems to be a local issue with your server. If you would like to get it solved, please open another, new thread and maybe prior check what happens, if you run the related scripts manualy (v-update-sys-hestia-all triggers v-update-sys-hestia with the package names hestia, hestia-nginx and hestia-php).

Hi all !
Kristankenney,ScIT thanks for the help !
Updated gpg key, there are no more problems!
Although when upgrading from 1.06 to 1.1.0, I installed this key …

1 Like