Error: nginx restart failed when issuing SSL

Hi,

I get Error: nginx restart failed every time I try to issue an SSL for a domain. I was not getting this before but suddenly I’m not able to issue SSL.

Running nginx -t gives this:

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: [emerg] open() "/var/log/apache2/domains/store64689.storelax.co.bytes" failed (24: Too many open files)
nginx: configuration file /etc/nginx/nginx.conf test failed
[email protected]:~# service apache2 restart
[email protected]:~# nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: [emerg] open() "/var/log/apache2/domains/store64689.storelax.co.bytes" failed (24: Too many open files)
nginx: configuration file /etc/nginx/nginx.conf test failed
[email protected]:~# systemctl edit --full nginx.service
[email protected]:~# service apache2 restart
[email protected]:~# systemctl reload nginx
[email protected]:~# systemctl status nginx
● nginx.service - nginx - high performance web server
     Loaded: loaded (/etc/systemd/system/nginx.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2022-11-16 14:11:15 CET; 2min 50s ago
       Docs: https://nginx.org/en/docs/
    Process: 1399663 ExecReload=/bin/sh -c /bin/kill -s HUP $(/bin/cat /var/run/nginx.pid) (code=exited, status=0/SUCCESS)
   Main PID: 1399464 (nginx)
      Tasks: 4 (limit: 4625)
     Memory: 111.1M
        CPU: 3.104s
     CGroup: /system.slice/nginx.service
             ├─1399464 "nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf"
             ├─1399666 "nginx: worker process" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" ""
             ├─1399667 "nginx: worker process" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" ""
             └─1399668 "nginx: cache manager process" "" "" "" "" "" "" "" "" "" "" "" ""

Nov 16 14:11:14 vmi1004915.contaboserver.net systemd[1]: Starting nginx - high performance web server...
Nov 16 14:11:15 vmi1004915.contaboserver.net systemd[1]: Started nginx - high performance web server.
Nov 16 14:13:24 vmi1004915.contaboserver.net systemd[1]: /etc/systemd/system/nginx.service:10: PIDFile= references a path below legacy directory /var/run/, updating /var/run/nginx.pid → /run/nginx.pid; pleas>
Nov 16 14:13:40 vmi1004915.contaboserver.net systemd[1]: Reloading nginx - high performance web server...
Nov 16 14:13:40 vmi1004915.contaboserver.net systemd[1]: Reloaded nginx - high performance web server.

https://docs.hestiacp.com/admin_docs/settings.html#error-24-too-many-open-files

Followed all the steps. Still getting same error.

Use a different VPS provider that allow more open files…

It has nothing to do with Hestia