Exceeding disk quota

I am running hestia on ubuntu vm on proxmox and we just had our first test today and users were able to exceed the quota that was set for their package. They were all using ftp clients.

If you are using LXC on Proxmox you can’t enable Quotas other otherwise enable them …

Proxmox ve is using lxc most likely right?

It depends what you select when you create the VM could be KVM or LXC

Yeah, I did not create this vm in a container so it should not be it. But nothing is stopping the user from adding more

Check the used quota for the user:

quota -w -s -u HereTheUser

Oh, it looks like the quotas were not actually set. Any idea of how to fix this?

Use this command:


quotaon: Your kernel probably supports ext4 quota feature but you are using external quota files. Please switch your filesystem to use ext4 quota feature as external quota files on ext4 are deprecated.
quotaon: cannot find /home/aquota.group on /dev/sdb [/home]
quotaon: cannot find /home/aquota.user on /dev/sdb [/home]
Error: quota can’t be enabled in /home

You can ignore that.

I think you can’t use quotas in Hestia if /home is mount on another partition, also, is that partition using ext4?

I don’t know how good this solution is but I just copied the files it did not find from another place on the system and it did not give me a error

If quotaon gave an error… I don’t think it is a good idea to do it manually. As I asked in my previous post, if /home is using xfs instead of ext4, you should not be able to use quotaon on that partition.

It is ext4. So?

If v-add-sys-quota wasn’t able to add quotas on /home…

Show the output of these commands:

quotaon -pa

And also this to check if quota params has been added to fstab:

cat /etc/fstab

Yeah the groups and users are enabled on both fstab and quotaon

Could it just have been permission issues due to it being on a seperate vm disk? could of just been a issue creating the file, but I am having no issues with it no more. I have tested it and it stops the upload. The quota can also be changed and it will update it.

Don’t think so, but I think it is not a good idea to copy quota files from another file system.

I would prefer to view the output of the commands but if that works… check again the quota for a user. Maybe you should update the user quota before:

v-update-user-quota HereTheUser
quota -w -s -u HereTheUser

yeah, I have been changing the quotas and the quota seems to change for the users with the package.

1 Like

btw here command output you asked for

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.