Exim does not obey to user disk quota


May be related to this thread https://forum.hestiacp.com/t/disk-quota-not-applied-to-mails/

File system quota is active. I run
repquota -s /
And I can see the user is being applied to file system quota.

in Exim config file for retries, I added this config line, meaning “don’t retry, just reject them”.

# Address or Domain    Error       Retries
# -----------------    -----       -------
     *                 quota

But, this does not take effect for newer hestia exim config file. One of my servers is still running 3-year-old Hestia, and quota works. I assume local email user delivery is now using transport dovecot_virtual_delivery , not local_delivery anymore. (when sieve is active).

Instead of Exim rejecting incoming emails, it just defers hundreds of them as mail queues. It seems Exim cannot see them as quota error, so it treats them as general error (with retries interval).

This is extracted log:

<[email protected]>: dovecot_virtual_delivery transport output: Not enough disk quota
** [email protected] F=<DL-AP-S***********@******.com> R=localuser T=dovecot_virtual_delivery: Child process of dovecot_virtual_delivery transport returned 77 (could mean permission denied) from command: /usr/lib/dovecot/dovecot-lda

There are 2 different quotas

  1. Mailbox quota set at dovecot level
  2. File system quotas …

Thanks for replying.

  1. All email accounts are set to unlimited disk quota
  2. The Hestia user is applied to a package which limits disk quota

If there is no disk space availble then the email can’t be delivered… Maybe on your old server disk quotas are not enabled?