Exim4 does not receive emails

I’m using
Hestia Control Panel: v1.1.1
Operating System: Debian 10.3 (x86_64)

I did several searches on the forum and google, but I couldn’t find any solution to my problem.

I used http://mxtoolbox.com to check the MX (No errors)

My problem:
I access the Roundcube and can send emails as usual
when I reply to these emails outside my server (example gmail) the email does not arrive.

Can you help me?

I’m sorry, but you wrote this already, also you got a detailed answer from @falzo, which I add again below:

I apologize for insisting on this help topic.

I did a shipping test by wordpress, it is authenticated and sends emails.
I tested using telnet on the server CLI, the email is also sent

Is there any way to reconfigure exim4?
I don’t know what else I can do.

Exim4 works already out of the box, there is no need to reconfigure.

Please follow the advice of @falzo for debuging your issue, start with an easy domain setup, verify that you xan send and receive emails, have proper records and communication - then proceed with the next step. But as he already properly wrote, we can’t help out here - we support if you have hestia related issues.

  • have you made sure your dns settings are correct?
  • have you accidentically blocked yourself incoming on port 25 with the firewall settings or forgotten to open that port on your providers firewall?
  • check your logfiles. do you see incoming connections from gmail getting rejected? do you see incoming connections at all?

mails don’t get lost at all, so if it doesn’t arrive in your inbox, what does the ‘not delivered’ message say? after 24h you’d at least should get a ‘deferred’ message or something alike…

I have to agree with @ScIT , this are basic server management task you should be able to manage yourself - hestia is intended to make setup and reoccuring tasks easier, however it’s not there to simply skip learning :wink: you still need to have everything around it setup correctly and know what you are doing - we can’t help with that.

if this sounds rude or disappointing I apologize. however, we really have no intention of nurturing the thought that hestia is a beginners product :man_shrugging:t2:

I agree with @falzo, it seems a problem with the DNS. Are you sure that the DNS are only configured in Hestia and there is nothinG conflicting in the company providing you the domain?

@realjumy @falzo Thanks for the replies

My domain is pointing to cloudflare by NS.

In Cloudflare I have the DNS mail entries for the server’s ip
I also have the MX entry pointing to the DNS mail entry

Doing a simple connection test with mxtoolbox.com it does not show an error

CloudFlare

I did a test of SMTPTest by mxtools and it is returning this to me.
https://mxtoolbox.com/SuperTool.aspx?action=mx%3Amelatoninavix.com&run=toolpage#

220 45.56.112.235 [609 ms]
EHLO keeper-us-east-1b.mxtoolbox.com
250-45.56.112.235 Hello keeper-us-east-1b.mxtoolbox.com [52.55.244.91]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-CHUNKING
250-STARTTLS
250 HELP [609 ms]
MAIL FROM:<[email protected]>
250 OK [616 ms]
RCPT TO:<[email protected]>
**550 relay not permitted [728 ms]**

A test was carried out on the ipok.com.br website with SMTP AUTH Banner
image

Firewall HestiacP

LOG Exim Mainlog

[email protected]:/var/log/exim4# cat mainlog
2020-04-22 12:12:49 1jRH3R-0000Ta-I2 <= [email protected] H=mail-il1-f182.google.com [209.85.166.182] P=esmtps X=TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128 CV=no SNI="mail.melatoninavix.com" K S=2960 DKIM=gmail.com [email protected]l.com
2020-04-22 12:12:49 1jRH3R-0000Ta-I2 => sistema <[email protected]> R=localuser_fwd_only T=devnull
2020-04-22 12:12:49 1jRH3R-0000Ta-I2 Completed
2020-04-22 12:18:34 1jRH90-0000a2-31 <= [email protected] H=mail-il1-f176.google.com [209.85.166.176] P=esmtps X=TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128 CV=no SNI="mail.melatoninavix.com" K S=2968 DKIM=gmail.com [email protected]l.com
2020-04-22 12:18:34 1jRH90-0000a2-31 => sistema <[email protected]> R=localuser_fwd_only T=devnull
2020-04-22 12:18:34 1jRH90-0000a2-31 Completed
2020-04-22 12:19:13 Start queue run: pid=2241
2020-04-22 12:19:13 1jR2AZ-0000DL-6q Message is frozen
2020-04-22 12:19:13 1jQyWV-0000Cm-Lz Message is frozen
2020-04-22 12:19:13 End queue run: pid=2241
2020-04-22 12:34:00 1jRHNw-0000sG-GD <= [email protected] H=mail-qk1-f181.google.com [209.85.222.181] P=esmtps X=TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128 CV=no SNI="mail.melatoninavix.com" K S=3035 DKIM=gmail.com [email protected]l.com
2020-04-22 12:34:00 1jRHNw-0000sG-GD => sistema <[email protected]> R=localuser_fwd_only T=devnull
2020-04-22 12:34:00 1jRHNw-0000sG-GD Completed

I might be wrong, but you should configure the DNS with Hestia, wait a day for the DNS to propagate, and then use CloudFlare. Starting from a Hestia’s default settings, Cloudflare should detect your DNS configuration and import it.

Try like that and check again (maybe you will have to delete your domain from Cloudflare first).

Just remember:

  • Always do backup of all configurations and system
  • The DNS take long to update, so you should wait when you start using Hestia’s DNS and then wait again before configuring Cloudflare again.
  • I can be wrong

Good luck!

really?

2020-04-22 12:12:49 1jRH3R-0000Ta-I2 => sistema [email protected] R=localuser_fwd_only T=devnull

sorry man, but obviously you setup your mail account that you are trying to send something to with a forward and to not keep a local copy.
so every mail comes in, gets forwarded (maybe) and saved in /dev/null aka deleted.

of course they won’t appear in your inbox then. :man_shrugging:t2: :grin:

2 Likes

PS: and probably because the forward then fails (if you forward back to gmail, it’s most likely just rejected because it’s a loop) the message ends up in the frozen queue, because it has nowhere else to go to.

Thanks for the reply @falzo @realjumy

I am not using any type of email forwarding.
Follow the hestiacp settings


image

Thanks for the answer.

I didn’t check any option not to keep a copy, how do I change it?

your logfile definitely says otherwise. also your initial question about catchall and forwarding suggest, that you tried quite some things before…

whatever you did change or not, something got messed up. probably best to remove the mail-account and the mail domain completely and then step-by-step add it again.

you could also try to simply set up another mail account that might not be borked already - just for testing purposes :wink:

however, your exim4 mailserver clearly receives messages. it just tries to forward them and deletes them right after. that’s a configuration issue caused by whatever else you might have already tried to fix it or achieve your initial goal to forward stuff. did you do some stuff on the console or add aliases manually to the exim config or something like that?

good thing though: at least your dns entries seems to be working as intended :wink:

1 Like

I will do step by step below:

image


image



I will test and already answer below.

Thank you very much @falzo

I hope that with this error of mine, I can help other users.