Exim4 with amazon SES

This request is due to our Digital Ocean droplet, the global ASN marked as UCEPROTOCAL3 problem.
Many people requested to DO via forum for past few years, but still they dont care…

my panel is,

-Hestia cP v.1.5.7
-Configured (/edit/server/) > Global SMTP Relay.

It works well while my hosted domains sending via php/html emails. It shows as via ‘Amazonses.com’. Thats good.

But when we recvd system emails to [email protected] .com, we forwarded to GMAIL.
It still shows as via ‘mypanel .com’.

How do i config to change the system mails from (via) ‘Amazonses.com’…?

mail form [email protected] are send via sendmail by default

Located in /usr/local/hestia/install/upgrade/manual/ is an file to set up phpmailer properly

Hi @eris,
Thank you for your kind replies. I copied your SH file & filled in all AWS valid details.
Rebooted my panel server. But still it shows via [email protected].
(find attached ref). also i set to notify via email on every ssh login. also the same.eximaws

Hestia uses:

SENDMAIL="$HESTIA/web/inc/mail-wrapper.php"

And should then send email with phpmailer…

Hi,
Just for my testing purpose,
even i deleted
‘/usr/local/hestia/conf/hestia.conf’
‘/usr/local/hestia/web/inc/mail-wrapper.php’

My system notifications to [email protected] .com i still shows as ‘via panel.com
So, it seems the settings are in somewhere else.

Hosted domains are follows as ‘via : amazonses’. But not system [email protected] .com…

OK,

  • What i realized was, the system mails are do’nt care about hestiacp or any applications except MTA. Because system mails supposed to send via MTA directly - not via any other applications.
  • This causing issue for me, because of VPS IP blocked by UCEPROTECT3
  • Nothing to do with hestia

Finally i settled this matter by using this link:
https://docs.aws.amazon.com/ses/latest/dg/send-email-sendmail.html

Now i could see my [email protected] .com emails to gmail are (sent via: amazonses)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.