Failed to connect , workbench

Hello good morning, I am trying to connect a database in hestia through the Workbench software but it tells me connection failure, why can it be?

This has already been discussed somewhere in our forum, there are two things to do:

  1. Add a exception to the hestia firewall to the mysql port - I suggest to limit it to your specific ip, otherwise it would be reachable from everywhere.
  2. Remove or set the bind value properly in the mariadb config.

Captura de Pantalla 2021-02-19 a la(s) 13.01.40

Thanks for your answer, I am new to Hestia and I am just investigating the issue, I had already configured the firewall, but I still do not succeed, what else can I miss, thanks again for your help


As ScIT mentioned you have to fix 2 things, and then try telnet to your server on port 3306, just to clarify where the problem is: on client or on server. Most of the time, as I remember, it was problem on client side. Could be incompatible connection method, wrong credentials or ip etc. But first check that you can connect on 3306


An option would be good to be able to connect from the outside to a database hosted in our hestiacp, we are going like other control panels do.

We do support it only users need to know how to config an Mysql and their firewall… We might need to add information to the docs… But even an google will fix the issue…

1 Like

The interesting thing is that it does not have to be configured by the user, but with an option that is done alone, as it is done in other control panels.

So you are asking for a new feature that consists of one click open port 3306, put mysql to listen to the world (or a given IP) and set fail2ban for mysql service.

Is that correct?


Maki, I always support easy 1-click toggle actions for the panel, but for what I know, I think that the development team might have other priorities.

They usually suggest to proceed with a pull request and they will consider including it in Hestia.

Since I don’t belong to the team and I can’t develop I am afraid I can’t help you with that.

Thanks for your answer I did the telnet test and I don’t have an answer, I still don’t know what I’m missing

I found it.
but There may be security issues

$ sudo nano /etc/mysql/mariadb.conf.d/50-server.cnf

and testing your terminer
$ nc -zv [your ip] 3306

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.