Failed To install Hestia Control Panel


I tried to install the Hestia control panel on Ubuntu 20.04 without PHP-FPM. It got failed. It gives this error.

I tried to install Nginx and Apache2 as a backend server. View the attached image.

Known issue

see for fix so you can install Hestia as it should be.

But why not PHP-FPM?

I have used PHP-FPM for my other VPS. But, I have observed that some time it creates a problem with the WordPress Plugins and overloads the server. So, I want to use Apache with Nginx as in Vestacp.

Providing a link is not solved my problem. :slightly_frowning_face:

well, basicly it does answer you all points :slight_smile:. The issue has been fixed and will be released with the next feature release ±/ in a week.

1 Like

May be, you are right. But, I am unable to understand how to fix it. I have tried 3 to 4 times on Ubuntu 18.04 to 20.04

But, the issue remain same.

As written, the related parts are in the issue report, if you dont know how to manualy implement them, you’ll need to wait for the 1.3.0 release in around a week or stick to fpm.

1 Like