Failed update&upgrade from bionic beaver& hestia prior 1.2


first of all I want to thank you all wonderful folks working so hard on HestiaCP. Found the donation button and have to convince few of my employers how much they save so they could pass some of savings to devs.

I needed to upgrade one server which had old hestiacp prior 1.2 I think it was 1.06. I ran apt-get update & apt-get upgrade and got a line warning that bionic was not anymore on distro list.

I added this: wget -qO - | sudo apt-key add -

and it started updating. Then something must have gone wrong badly because upgrade failed on bionic part but hestiacp got updated. Symptoms are like very lazy hestia Gui and problem is there would be not it because has to make a bunch of dev accounts there. Also it would be very nice to get bionic upgraded.

I do have a snapshot and server is not a live one but how should I do this update&upgrade right?
I am not an server administrator but sometimes I have to mess up with them too :wink:
So in this kind of situations hestiacp shines because it makes so easy to manage servers without shell.

I think I need to add some repos and remove others but not sure in this case.

Also checked out some logs and latest versions automatic ban iplists work like a charm, server knocking has reduced nicely and no iron fw needed in some servers which adds to cost savings.

Together with Cloudflare which is well supported in Hestia this is a remarkable server administration solution at my point of view.

All the best and keep up the great job,

you could try running dpkg --configure -a or run apt update and apt dist-upgrade seperately again.

without knowing the output or error message, there sadly is not enough info to help you out further :wink:

and what do you mean by ‘very lazy’? slow loading? all parts in the gui or only some specific functions?

PS: and thanks for the nice feedback, obviously we love to hear about satisfied users :smiley:

Hi falzo,
I am very sorry for late response. Could not agree more with my problem description :wink: I get to hear too often “it don’t work, fix it” sentences without any clues where to begin haunt those problems down. I made an sms integration to few forms last week and messaging worked well to my cell number and api did not give any errors. One boss whose cells those messages should have ended in production gave me that scary sentence and I asked him three times do you have some number blocking or routing in in place? Got no answer to that too but just “don’t work, fix it”. After SMS gateway provider escalated problem to local carrier it was found there was an blocking in place in his phone :roll_eyes:

For the that kind of reasons I was very busy but now had the time to investigate why Hestia upgraded but ubuntu upgrade failed.

The original version of 18.04 LTS was an dev server and had some obsolete packages. Perhaps some network issues had even broken some.

I did not wan’t to start from clean slate but did fixed the server with below because got issues like:

The following packages have been kept back:
name_of_package1 name_of_package_2
and upgrade refused to start

So did install/purge on packages on the above list
after that
sudo apt-get autoremove
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt install do-release-upgrade

And now:
cat /etc/os-release
VERSION=“20.04.1 LTS (Focal Fossa)”

and also latest hestiacp works fine so it must have been some package inconsistency/broken package to begin with. So this was no way Hestia related but server packages gone awry. Just thought to list steps taken to fix server side issues if it helps somebody with similar issues.

All the best,


glad to hear you got it solved, and thanks for reporting back in detail.

so much this! much appreciated :smiley:

1 Like