File Manager: Unknown error (Error 500)

Hi,

I updated to the newest version of Hestia and when I like to open the file manager. I see this.

Only error I see with developer tools is
500 Internal Server error on https://panel.url/fm/?r=/getdir

Thanks

1 Like

what is your ssh port and what is the content of /home/admin/.ssh folder?

1 Like

Hey,

Content of the folder are as follow

I did change my ssh port to 9798

logout and relogin from hestia panel

Still got the same error. When I logged in with a different user and then switched to admin account it started working normally.

Glad you solved it.

Some extra context: the SSH port is stored in user session so a logout will destroy it and re-detect the custom port on login

1 Like

Can we force this fix, without needing an additional account to switch to? Perhaps by deleting a cached file.
(Haven’t created any user accounts yet, other than ‘admin’.)
Just a thought.

rm /home/admin/.ssh/* if you did not created a ssh key yet (except file manager) will delete the key

Then logout and try to re login

Had similar issues yesterday on a server. After reboot it was fixed.

2 Likes

Hestia automatically updates to version 1.2 which seems great to me, but when entering the file manager it gives me an error. perform system updates to see if it repaired, reinstall hestia and even reboot the server; but the error persists. I appreciate any help.

VPS
Ubuntu 20.04
Hestia 1.2.0

Please check contents of /home/user/.ssh

If you haven’t cleared them please remove the both authorized_keys and file manager key

Then login / logout

1 Like

I can’t see any files on folders except on web. Is it by design or error in my installation?

.conf / mail is only accessed as root and should not been used by any user.

1 Like

The FileManager is using sftp to acces the files so anything that is accesible with a classic sftp client like filezilla/winscp/etc should work with the fm too

So only web folder is accessible through file manager.

Not only the web, basicly the user home folder.

But as I said earlier I can’t see any files in other folders in home/user.

Do you get an unknown error as written above?

Despite following the instructions, it keeps giving me the same error. You can detail more the solution that it proposes. Thank you very much in advance.

@ALEX try to login over sftp or check /var/log/auth.log for any strange errors.

I must mention that change the ssh port for security to 10022 and deny permissions to the root user and only enter the terminal from another user and once logged in, just login as root. I imagine that because of this it is that I cannot enter by sftp.