File Manager Unknown error hestiacp 1.8.5

Hi -

I saw many topics about this concern, but no answer fr the issue.

We’re receiving an “Unknown error” message on file manager for all users.

Java script console says:

POST 500
(anonymous) @ xhr.js:177
e.exports @ xhr.js:13
e.exports @ dispatchRequest.js:52
Promise.then (async)
u.request @ Axios.js:61
r.forEach.u. @ Axios.js:87
(anonymous) @ bind.js:9
(anonymous) @ api.js:54
getDir @ api.js:53
loadFiles @ Browser.vue:284
mounted @ Browser.vue:241
nt @ vue.runtime.esm.js:1854
Nn @ vue.runtime.esm.js:4219
insert @ vue.runtime.esm.js:3139
O @ vue.runtime.esm.js:6346
(anonymous) @ vue.runtime.esm.js:6565
An.e._update @ vue.runtime.esm.js:3948
r @ vue.runtime.esm.js:4066
nr.get @ vue.runtime.esm.js:4479 @ vue.runtime.esm.js:4554
Kn @ vue.runtime.esm.js:4310
(anonymous) @ vue.runtime.esm.js:1980
ct @ vue.runtime.esm.js:1906
Promise.then (async)
at @ vue.runtime.esm.js:1933
pt @ vue.runtime.esm.js:1990
er @ vue.runtime.esm.js:4402
nr.update @ vue.runtime.esm.js:4544
me.notify @ vue.runtime.esm.js:730
set @ vue.runtime.esm.js:1055
initialize @ store.js:34
(anonymous) @ vuex.esm.js:785
(anonymous) @ vuex.esm.js:407
(anonymous) @ vuex.esm.js:406
m._withCommit @ vuex.esm.js:565
m.commit @ vuex.esm.js:405
commit @ vuex.esm.js:350
(anonymous) @ main.js:46
Promise.then (async)
(anonymous) @ main.js:45
Promise.then (async)
created @ main.js:42
nt @ vue.runtime.esm.js:1854
Nn @ vue.runtime.esm.js:4219
e._init @ vue.runtime.esm.js:5008
kr @ vue.runtime.esm.js:5085
93b7 @ main.js:36
t @ bootstrap:79
0 @ app.js?1674651109:1
t @ bootstrap:79
o @ bootstrap:45
a @ bootstrap:32
(anonymous) @ chunk-vendors.js?1674651109:1

We tried remove and install the FM module and have no success.

sshd_config files are allowed as shown:

Screen Shot 2023-08-22 at 9.46.42 AM

Our system info:

Any ideas will be welcome.

Thank in advance for your help…

Check /var/log/hestia-nginx/nginx-error.log

Hi @eris -

Thanks for your quick response.

The error shows the following:

2023/08/22 10:26:36 [error] 4253#0: *1 FastCGI sent in stderr: "PHP message: PHP Notice: Invalid SFTP packet size in /usr/local/hestia/web/fm/vendor/phpseclib/phpsec>

Stack trace:

#0 /usr/local/hestia/web/fm/vendor/league/flysystem-sftp/src/SftpAdapter.php(208): League\Flysystem\Sftp\SftpAdapter->setConnectionRoot()

#1 /usr/local/hestia/web/fm/vendor/league/flysystem/src/Adapter/AbstractFtpAdapter.php(650): League\Flysystem\Sftp\SftpAdapter->connect()

#2 /usr/local/hestia/web/fm/vendor/league/flysystem-sftp/src/SftpAdapter.php(360): League\Flysystem\Adapter\AbstractFtpAdapter->getConnection()

#3 /usr/local/hestia/web/fm/vendor/league/flysystem/src/Adapter/AbstractFtpAdapter.php(338): League\Flysystem\Sftp\SftpAdapter->listDirectoryContents()

#4 /usr/local/hestia/web/fm/vendor/league/flysystem/src/Filesystem.php(272): League\Flysystem\Adapter\AbstractFtpAdapter->listContents()

#5 /usr/local/hestia/web/fm/backend/Services/Storage/Filesystem.php(199): League\Flysystem\Files" while reading response header from upstream, client:, >

Thanks for your help…

Show the output of this command:

grep -ri 'sftp\|AllowUsers\|Pubkey\|Port' /etc/ssh/sshd_config /etc/ssh/sshd_config.d/

The output is as follows:

root@srv:~# grep -ri ‘sftp|AllowUsers|Pubkey|Port’ /etc/ssh/sshd_config /etc/ssh/sshd_config.d/

/etc/ssh/sshd_config:#Port 22

/etc/ssh/sshd_config:PubkeyAuthentication yes

/etc/ssh/sshd_config:#GatewayPorts no

/etc/ssh/sshd_config:#Subsystem sftp-server

/etc/ssh/sshd_config:# Hestia SFTP Chroot

/etc/ssh/sshd_config:Match User sftp_dummy99,admin,ap,edn,edn_ftp,edn_pbx,edn_portal

/etc/ssh/sshd_config: ForceCommand internal-sftp

Change this in /etc/ssh/sshd_config file:

#Subsystem sftp-server

To this:

Subsystem sftp internal-sftp

Restart ssh service

systemctl restart ssh.service

And try again.

1 Like

Wow -

Thank you @sahsanu, you guys are the best…!!

Problem solved and case closed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.