Filemanager Unknown error

Hello! I have experienced an issue where the Filemanager on fresh installations of Ubuntu 22.04 and Debian 11 Linux both give an “Unknown error” message. I want to emphasize that this occurs on fresh installations. I have also noticed the same error on the Filemanager in the Demo here, so it’s likely a general issue. Could you please look into this error? Thank you very much for your help.

Demo can’t access the filemanger due to demo restrictions

Please check /var/log/hestia/nginx-error.log

I have attached a screenshot of it.

Could not connect with admin is ssh running? Can you login with sftp as admin?

Yes, I can log in as root. This is a fresh install.

And as admin user?

Putty does not allow logging in with the admin name.

Check /var/log/auth.log and check the error.

We managed to solve the error. I will describe what worked for me.

nano /etc/ssh/sshd_config
This must be enabled:
PermitRootLogin yes
This should be prohibited:
UseDNS no
This must be deleted before configuring Hestia:
PermitRootLogin yes
AllowUsers root

Changing the above settings together fixed the file manager error.

You have restricted access only to:
AllowUsers root

That would explain why…

We use SFTP for security as it is more secure than run everything under a root users and change it. Then you should never sftp login support

And I noticed it’s really fast with un/zipping or with file operations in general. Much faster than it used to be in cPanel.

I’d work with public/private keys instead of root logins. PermitRootLogin is set to “prohibit-password” on my server.
FM works. I have no UseDNS setting.
Below #Hestia SFTP Chroot
There are some automatic settings made from HestiaCP: Match User … (your users).
As eris wrote … I think if you get rid of “AllowUsers root” it should work.