Fossbilling / Nginx template in need

For the past couple of days I’ve been trying to get Fossbilling to work on my Ubuntu/HestiaCP box (Nginx only, no Apache).

I tried to create a template for Fossbilling based on default.tpl / default.stpl, and the Fossbilling documentation.

Despite all the attempts, I could not get the URL rewrite to work.

If anyone can share a working template for Fossbilling / Nginx it will be greatly appreciated. Thank you.

Here is my latest build for fossbilling.stpl


server {
listen %ip%:%web_ssl_port% ssl;
server_name %domain_idn% %alias_idn%;
root %sdocroot%;
index index.php index.html index.htm;
access_log /var/log/nginx/domains/%domain%.log combined;
access_log /var/log/nginx/domains/%domain%.bytes bytes;
error_log /var/log/nginx/domains/%domain%.error.log error;

ssl_certificate     %ssl_pem%;
ssl_certificate_key %ssl_key%;
ssl_stapling        on;
ssl_stapling_verify on;

# TLS 1.3 0-RTT anti-replay
if ($anti_replay = 307) { return 307 https://$host$request_uri; }
if ($anti_replay = 425) { return 425; }

include %home%/%user%/conf/web/%domain%/nginx.hsts.conf*;

try_files $uri $uri/ @rewrite;
sendfile off;
include /etc/nginx/mime.types;
# Block access to sensitive files and return 404 to make it indistinguishable from a missing file
location ~* .(ini|sh|inc|bak|twig|sql)$ {
	return 404;
# Block access to hidden files except .well-known
location ~ /\.(?!well-known\/) {
	return 404;
# Disable PHP execution in /uploads
location ~* /uploads/.*\.php$ {
	return 404;
# Deny access to /data
location ~* /data/ {
	return 404;
location @rewrite {
	rewrite ^/page/(.*)$ /index.php?_url=/custompages/$1;
	rewrite ^/(.*)$ /index.php?_url=/$1;

location / {
	location ~* ^.+\.(jpeg|jpg|png|webp|gif|bmp|ico|svg|css|js)$ {
		expires max;
		fastcgi_hide_header "Set-Cookie";

	location ~ [^/]\.php(/|$) {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;

		include /etc/nginx/fastcgi_params;

		fastcgi_index index.php;
		fastcgi_param PATH_INFO       $fastcgi_path_info;
		fastcgi_param HTTP_EARLY_DATA $rfc_early_data if_not_empty;
		fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
		fastcgi_intercept_errors on;

		fastcgi_pass %backend_lsnr%;

		include %home%/%user%/conf/web/%domain%/nginx.fastcgi_cache.conf*;

location /error/ {
	alias %home%/%user%/web/%domain%/document_errors/;

location /vstats/ {
	alias   %home%/%user%/web/%domain%/stats/;
	include %home%/%user%/web/%domain%/stats/auth.conf*;

proxy_hide_header Upgrade;

include /etc/nginx/conf.d/*;
include /etc/nginx/conf.d/*;
include %home%/%user%/conf/web/%domain%/nginx.ssl.conf_*;


and web-templates/templates/nginx/php-fpm/fossbilling.stpl at master · jaapmarcus/web-templates · GitHub

Thank you so much, it works perfectly!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.