Fresh installation of Hestia CP 1.4.6 and... don't rule fine

Hi there.
Today i install a new instance o HestiaCP in an VPS (with OVH).
I use linux ubuntu 20.04

In the install process i use a personalized line to unnatended installation, like this:

bash -f -a yes -w yes -o yes -v yes -k yes -m yes -g no -x yes -z yes -c no -t yes -i yes -b yes -q yes -l es -s -e [email protected] -p mykeyword

I access to “” and can access to hestiaCP and seems to be all ok

-create a user (*and put on this account the DNS of domain provider
-then i create a SUBdomain (in domain provider i redirect the ip4 and ipv6 to this VPS)
-then i use the wizard to install on this domain an instance of nextCloud (the database was created without problems)
-the ftp account, to access to this domain folders, was created (and i access on it with filezilla)


-when i try to access to domain ( not open nothing
-when i try to access to phpmyadmin of this dababase instance, can’t open

Any idea what might be going on?

I can’t access xx.xx.xx.156

Are you use the ports are correctly open

The DNS resolution works fine.

I get a 403 error.

Your server is rejecting the connection.

My first thought was to stop the firewall, but there was no change.

I can access the control panel url with port 8083.

As jlguerrero says, the dns seems to be fine and the redirection also checked, both for ip4 and ip6.

Right now I’m not sure what other tests I can do or where the error is jumping to.

jlguerrero, “Your server is rejecting the connection”.

That’s true, but why?

Is nginx working for that domain?

nginx -t

If you uninstall the app do you see the “Success” page?

The ports that need to be open are 80 and 443

now y reboot the vps.

the command “nginx -t” returns:

…nginx.conf syntax is ok
…nginx.conf test is successful

now works!!! :slight_smile:

but the phpmyadmin returns a blank page

Your web is up now

1 Like


I just need to see what happens with phpmyadmin

Have a look here:

phpmyadmin should not be affected …

-f should always be last I have seen issues in the past with it …

I am currently testing the installer. I had no issue the last time I tested it.

at the final of line? would be something like this?

bash -a yes -w yes -o yes -v yes -k yes -m yes -g no -x yes -z yes -c no -t yes -i yes -b yes -q yes -l es -s -e [email protected] -p mykeyword **-f**

Tell me the correct way for me to replace it in my know how notes.

I could see that my main control panel login ( still did not have the lets encrypt certificate (I temporarily logged in with a security exception).

… and when I try to open phpmyadmin it does so:

Although I add https by hand, it still opened with http, so I thought that maybe that’s the reason why I can’t access it properly. I have proceeded to enable the certificate and as soon as it propagates I will test it.
Do you think this could be it?

  • Update: The certificate is necessary, but it did not solve the problem.

It should always be with out **

But I am testing now for a moment

Just did a test without any issues with the string above after moving -f to the end.

1 Like

I read in the HestiaCP manuals that for security reasons the firewall does not have port 3306 open for access to phpmyadmin, but in my case it was the same, because even adding this port, like disabling the firewall, it still failed.

In the end I reinstalled everything and now I’m crossing my fingers that nothing fails.

:frowning: :sleepy: It is tedious to waste hours and hours and have to redo over and over again without the certainty of doing it right (even if I follow the instructions to the letter and hope that some component doesn’t spark for God knows what reason.

PHPmyadmin does not require port 3306 open

There was a bug in 1.4.6 that caused issues with v-restart-service in 1.4.7 it should be working right now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.