Gateway Timeout -phpmyadmin

Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.

I’m having problems uploading database file 8MB

I’ve change max_allowed_packet in the panel, that’s not the problem.

I looked for $cfg['ExecTimeLimit'] in config.inc.php and could not find it to edit.

The only php.ini file I can find and edit is in /usr/local/hestia/php/lib and I changed max_execution_time & max_input_time and that did not work.

Is there another file anywhere I can edit?

It looks like you edit the wrong config file - if you want to upload it on a website, checkout /etc/php/. Also have a look in the web log files, this may give you more ifnormation than “only” the timeout.

I looked in log and the only warning I see is:
[Warning] Aborted connection 91 to db: ‘unconnected’ user: ‘pma’ host: ‘localhost’ (Got timeout reading communication packets)

I edited php.ini in /etc/php/7.3 and /etc/php/7.4 and that did not work.
Funny thing is when I refresh phpmyadmin it’s uploaded the whole database.

I’ll keep having a look and see if I can sort it.

Can you please share more informations about your system? OS, Version, Hestia Version, Installation String (full version (–apache yes/no, not -a yes).

Dedicated server
Debian 10.3 (x86_64)
Hestia v1.1.1
bash hst-install.sh --multiphp yes -c no -t no -r 8090 -e [email protected] -p mypass -s mydomain.com

I’m getting the same 504 gateway timeout in hestia 1.2.3 when I import databases in phpmyadmin 1MB or over?

I’ve tried increasing values in:
/etc/php/7.3/fpm/php.ini
max_execution_time

/etc/nginx/nginx.conf
fastcgi_connect_timeout
fastcgi_read_timeout
fastcgi_send_timeout

proxy_connect_timeout
proxy_read_timeout
proxy_send_timeout

/etc/mysql/my.cnf
wait_timeout

Any ideas on how to fix this?

Thanks, Liam

So I found out that the gateway timeout was actually coming from the apache timeout setting which is 30 seconds.

I increased this timeout setting in apache2.conf and was able to see the true sql error in phpmyadmin.

/etc/apache2/apache2.conf

1 Like

For large sql files I would always suggest use CLI. Way more save and reliable…

what is cli?

Command line interface.

mysqldump -u username -p databasename < dataimport.sql
2 Likes

I had the same problem, but I could also solve it by changing the seconds in apache2

Please creata a new topic it doesn’t make sense to update an 6 months old topic…