Gmail Forwarding always going to SPAM Folder

Hello, i’ve installed a HestiaCP in a fresh vps a couple of days ago, something that took my attention was that all my e-mails was going to the Spam folder of Gmail accounts.

Tested with Roundcube and Forwarding with Gmail.

I’m using Cloudflare and my score in is 10/10, have SSL for Mail and Webmail enabled.

Do i understand it correctly, you forward your e-mails from the hestia mailbox account to gmail and they get spamed?

Yepp, and also when i send from Roundcube it goes to the spam folder, checked sending and replying to different gmail and outlook accounts and the emails always land into the Spam folder, even the replies.

Forwarding emails to google inst a good idea at all: You do not own the domains you want to forward, dkim and spf missmatches. Better you setup a pop download on gmail’s site, which will import the emails for you.

Also email to o365 and google depends on ip and reputation, sometimes it isnt also clear why you get into spam - even when all is setup properly and good reputation. There is nothing that we can do from hestia side to more optimize it than get a 10 out of 10 from mail-tester.

1 Like

If all mail-tester checks are green without any warnings, then most likely your sending IP is blacklisted or has a bad reputation

I have another VPS with Vestacp on the same server with a very different ip and it always worked good, never sent to a spam folder before.

I have a server with multiple sites of my clients and in cloudflare mx record i have to use “” and in gmail alias have to add “” to make it work, if i add “” in cloudflare mails are not sent, and if i add “” in gmail, google can’t reach the server, in my vesta installation i always used to use “” in both cases.
Finally when i do a MXLOOKUP to my webdomain it shows this MX Record “

Never seen something like this before

I just can repeat myself: This isnt a hestia or vesta issue, this is due to blacklisting and/or bad ip reputation - nothing we can change or help from our side :slight_smile:.

1 Like

You really don’t want to forward your emails to Google. Let’s suppose for a moment that your email address is [email protected] and your Gmail address is [email protected]. Whenever someone sends a SPAM message to your [email protected] address, that message will get forwarded to your Gmail address. Gmail will then decide that the message is SPAM and flag it.

If the above happens a few times, then Gmail will know that the domain is a SPAM domain and might flag it or do other nasty stuff to it. Rule of thumb: never forward email to Google!

Email is complicated and is becoming increasingly more complicated with all the anti-spam features. You really don’t want another layer of complexity >.<

Another VPS means another IP address, different network, different settings, etc. There are so many factors that play a role… It’s not just Hestia.


Thank you all for your kind replies, i fixed the issue!

Checking this site “” found out that my IP address “” was really new and other ips with the same numbers in the first three sections of the ip had neutral reputations too.

Also checked my old ip for the server that works “”, found that a big list of ips was using the same first three sections of the ip including mine, and had a good mail reputation.

So asked my vps provider to change my ip to “”, reinstalled the server, and now all my emails are sent to the inbox folder :slight_smile: