Gzip is using a lot of ram

image
image
gzip is using a lot of ram. Is there a way to turn it off? It would be convenient if I could manually start it when I wanted to

I have a 6 processor and 16 GB of RAM. but the websites on my server freeze sometimes. Could this be due to gzip using too much RAM?

No but if you create a back up every min it will consume a lot of powe

Understood, thanks

image

Is this normal? Can you give any advice to improve this?

Kill the processes…

https://forum.hestiacp.com/uploads/default/original/2X/7/71217e99334ff9da97f8d8cb0d87cc3631f0f831.jpeg

You made a backup every min

I created it for testing purposes, I forgot to delete it :face_with_head_bandage:


I uninstalled it but it’s still backing up
image
First of all, I apologize for asking so many questions. I don’t have enough experience, so I need your help :man_facepalming:

remove all folders starting with tmp, if you havent killed the processes, reboot the server once. load should be below 3-4, depending on what you’re running on the server.

every minute I removed the backup command and restarted the server, the load decreased significantly, thank you
cronn

hmm, 4.3 is still a bit high, please check the processes again, just to be sure.

Whenever a Cron starts with * it will execute every minute.

So if you have * * */2 * * it will run every minute of every hour of every day that is even

If you want something to run every two days, then:

5 0 */2 * *

This will run at 00:05 every even day

https://crontab-generator.org/ is a handy tool to build up crontab commands if you don’t know them off by hand :slight_smile:

image
Thanks, I optimized the script, now I have a good result

Thank you :+1:

Thank you

I have enough server resources, but sometimes my projects start running slowly. Are these settings correct for 6 cpu, 16gb ram(apache+php+fpm+nginx)?

Global configuration

PidFile ${APACHE_PID_FILE}
Timeout 30
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 10

IfModule mpm_prefork_module
StartServers 8
MinSpareServers 5
MaxSpareServers 20
ServerLimit 256
MaxClients 200
MaxRequestsPerChild 4500
IfModule

IfModule mpm_worker_module
StartServers 2
MinSpareThreads 25
MaxSpareThreads 75
ThreadLimit 64
ThreadsPerChild 25
MaxClients 200
MaxRequestsPerChild 4000
IfModule

IfModule mpm_event_module
StartServers 2
MinSpareThreads 25
MaxSpareThreads 75
ThreadLimit 64
ThreadsPerChild 25
MaxClients 200
MaxRequestsPerChild 4000
IfModule

http {
# Main settings
sendfile on;
tcp_nopush on;
tcp_nodelay on;
client_header_timeout 180s;
client_body_timeout 180s;
client_header_buffer_size 2k;
client_body_buffer_size 256k;
client_max_body_size 256m;
large_client_header_buffers 4 8k;
send_timeout 60s;
keepalive_timeout 30s;
keepalive_requests 100000;
reset_timedout_connection on;
server_tokens off;
server_name_in_redirect off;
server_names_hash_max_size 512;
server_names_hash_bucket_size 512;
charset utf-8;

# FastCGI settings
fastcgi_buffers                 4 256k;
fastcgi_buffer_size             256k;
fastcgi_busy_buffers_size       256k;
fastcgi_temp_file_write_size    256k;
fastcgi_connect_timeout         30s;
fastcgi_read_timeout            300s;
fastcgi_send_timeout            180s;
fastcgi_cache_lock              on;
fastcgi_cache_lock_timeout      5s;
fastcgi_cache_background_update on;
fastcgi_cache_revalidate        on;

# Proxy settings
proxy_redirect                  off;
proxy_set_header                Host $host;
proxy_set_header                X-Real-IP $remote_addr;
proxy_set_header                X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_pass_header               Set-Cookie;
proxy_buffers                   32 4k;
proxy_connect_timeout           30s;
proxy_read_timeout              300s;
proxy_send_timeout              180s;

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.