Hestia 1.1.0 BETA - Cronjob notifications

Dear all,

I’m still playing with DEBIAN 10 / HST 1.1.0 and i found something i’m not sure how to handle.
I’ve set a couple of cronjobs from HST and are working fine. The only issue i get is about CRON notifications. Seems are running not with the cron user i set in HST because i get this mail notification every time cron is triggered :

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

sudo: no tty present and no askpass program specified

So i tried to turn off cron notification from HST and all the emails now are marked as frozen and still in exim mail queue.

My question is : Is it normal that crons send everytime the above notification? If yes, it sounds as permission problem.

Secondly, can HST avoid to keep frozen messages in EXIM queue and force to delete it manually?

Thank you again for your super work and sorry if i miss something. I’m not reading all the forum topics :slight_smile:


Just exactly googled your string, points me to this site: https://www.cyberciti.biz/faq/exim-remove-all-messages-from-the-mail-queue/

It looks like you have a permission issue, what’s inside your cron scripts?

Hi @ScIT, yes, i know, but my point is that i should not see all these “frozen” mails. But it’s related to cron permissions i guess, that are producing these messages.

i’m just testing MAUTIC installation (https://www.mautic.org/) and the crons are the followings : https://www.mautic.org/docs/en/setup/cron_jobs.html
Mautic is based on symfony, so commands are likely : ```
php console mautic:segments:update or php console mautic:campaigns:update and i’m not sure what’s inside. Here a direct GIT link for “console” : https://github.com/mautic/mautic/blob/staging/app/console


the message you get mailed appears, when a user is not correctly configured in sudoers to work without a password request but tries to run commands with sudo. obviously cron has no chance to ask for the password, as it runs headless/non interactive

turning off mail notifications (how exactly did you do that?) is not a solution, as your crons simply won’t run through. you need to fix the sudo permissions for that user you are running the commands as. :wink:


Hi @falzo,

Thanks for your time.
Regarding cronjobs, I’m just using Hestia.
With “User A”, I add some crons for mautic in crons section of “User A”. I’m not using ADMIN, but a regular unprivileged user created within HST.
Doing that, I get the cron notifications.

To turn off cron notifications, I just press the button “turn off notifications” still in HST “User A” crons section.


@Ubi thanks for clarifying, do your commands contain ‘sudo’ ?
regular users obivously are not added to sudo nor allowed to have such privilege escalation.
if that’s not it, then maybe mautic itself tries to sudo something within its cron-script?

for the notifications I have to admit I never used that function, so need to check for myself, what that does :wink:
some error messages can’t be send to void anyway and therefore might still cause cron to have some output - which the system then obviously tries to send out via mail nevertheless.

as said above I still strongly advise to try and fix the cause, as the message suggest that your mautic cron-script won’t do anything at all right now

Hi @falzo,
thank you for the tip, just removed sudo (sorry,my bad) and it works fine with regular user.


1 Like