HESTIA 1.8.0 Backend block

Hi Guys,
FIRST a great thanks for making something out of the original VESTA…

TODAY one of my servers did an auto-update to 1.8.0 (ubuntu 22.04)…
AFTER the update ALL (4) DNS peers FAILED to update and suspended…
ATTEMPT to login to HESTIACP FAILED = NO ACCESS / page not loading

  1. server restart - same result…
  2. sites are UP = OK, ssh is running and accessible = OK
  3. HESTIA is started AND running = OK
  4. CAUSE found: HESTIA does NO longer respect the custom backend port in the hestia.conf
  5. TEMP Solution… ADD default 8083 back to the firewall… and load page with that port
    With this temo solution backend DOES load…
    Where to look for the hardcoded port 8083 and bring it back to original behaviour (i.e. read hestia.conf)???


v-change-sys-port randomnewport
v-change-sys-port port

Hello & Thanks…

Is is this on purpose???
custom port WAS set previously and working on <=17.x
just observing that this is the first update that breaks this :wink:


It should keep it as it was but we have related a new version of Nginx and it causes the port to be changed

Thanks again…
as I said hestia.conf DID HAVE the custom port…
setting it again as per your guidance FIXED the problem and I have removed the default port from the firewall. DNS seems to work again too :wink:
However, for me it means no automatic updates without breaking the whole cluster (obviously all are set to use custom port and FAIL after this update).


I will need to check what is going wrong.

Will check it out when I have time

Please create a bug report at GitHub - hestiacp/hestiacp: Hestia Control Panel | A lightweight and powerful control panel for the modern web.

1 Like

Thanks Eris,

opened bug on github as suggested
for those who encounter the problem - your suggestion DOES resolve the immediate problem.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.