Hestia Beta 1.4 Install question

After fixing the dependency problems with zstd and sysstat, I tried to install Hestia 1.4 beta using
wget https://apt.hestiacp.com/beta/hestia_1.4.0~beta_amd64.deb
dpkg -i hestia_1.4.0~beta_amd64.deb
which ended with the line
Setting up hestia (1.4.0~beta) …
But despite searching the documentation, I do not know what command comes next. I tried
bash hst-install.sh
The reply was
bash: hst-install.sh: No such file or directory
I then tried
v-update-sys-hestia-git hestiacp beta install
The reply was:
bash: v-update-sys-hestia-git: command not found
I am hoping someone can tell me what command comes next as I really want to try out Hestia 1.4 beta.

dpkg -i hestia_1.4.0~beta_amd64.deb only works on systems where Hestia is allready installed. If you want to install the beta on a new install you have to do the following:

  1. cd /root/
  2. Download

And the package https://apt.hestiacp.com/beta/hestia_1.4.0~beta_amd64.deb

  1. Run the following command:

chmod +x hst-install-{os}.sh
./hst-install-{os}.sh --with-debs /root/

Then follow the instructions you can modify the setup with

Thanks for this advice. I started an SSH session as root and entered:
cd /root/

I then entered:
wget https://raw.githubusercontent.com/hestiacp/hestiacp/main/install/hst-install-debian.sh

I then entered:
wget https://apt.hestiacp.com/beta/hestia_1.4.0~beta_amd64.deb

I then entered:
chmod +x hst-install-{os}.sh
./hst-install-{os}.sh --with-debs /root/

But the terminal replied:
-bash: ./hst-install-{os}.sh: No such file or directory

I am installing this on a new debian 10 server.
I am hoping you can give me the correct final command.
Thanks again for your help.

replace {os} with the word debian

Thank you. Your suggestion worked!
Here were the final two commands:
chmod +x hst-install-debian.sh
./hst-install-debian.sh --with-debs /root/

For others wanting to install Hestia 1.4 beta on a Debian 10 server, these are the commands for the two dependencies you may need to install before installing Hestia:

sudo apt-get install zstd
sudo apt install sysstat
sudo nano /etc/default/sysstat
Change the variable “ENABLED” from “false” to “true”
exit the nano editor after saving the file.
sudo systemctl enable sysstat
sudo systemctl start sysstat
sudo systemctl status sysstat
Then type q to close the screen.

I am now exploring Hestia 1.4 beta. So far, it looks pretty good. Thanks again for your help.


zstd and sysstat are include in the install script

When Hestiacp 1.4 stable version release?

@shahidirfan I believe next week according to @eris thats if everything checks out, although there’s still bug squashing still to do so my guess maybe the week after the next. Keep testing and report in, in the mean time.


Try for test to install to proxmox LXC-container debian 10:

[ * ] Configuring system settings…
Info: Cannot remount /proc (LXC containers require additional perm added to host apparmor profile)

which additional perm need for hestiacp?

I try to install to debian10 standard, version 10.7 image.
Was problem with dependencies, when I start install hestia warning about postfix* and hestia*

Installer suggested to delete automatically, but not can and I must to remove it manually.
Also was warning about

[ * ] Configure System IP…
cat: /usr/local/hestia/data/ips/ No such file or directory

It need to changed on the Host OS level.

Check Unable to re-mount /proc in Proxmox 3 containers? | Proxmox Support Forum

It limits users to see processes owned by an other user. It is not really required but only an additional security feature.

Hestia should always be installed on a clean system. Installing first the package and then the install script will cause for issues.

[ * ] Configure System IP…
cat: /usr/local/hestia/data/ips/ No such file or directory

Maybe caused by the fact the hestia package was already installed. Don’t know fo sure… Haven’t seen the issue yet…

I try reinstal debian and try to test in clean system

install on clean system requre uninstall postfix* and hestiacp installing it automatically someself

I use commands:
cd /root/
wget https://raw.githubusercontent.com/hestiacp/hestiacp/main/install/hst-install-debian.sh
wget https://apt.hestiacp.com/beta/hestia_1.4.0~beta_amd64.deb
chmod +x hst-install-debian.sh
./hst-install-debian.sh --with-debs /root/

did I miss anything?

Uninstall Postfix is normal most images use it as default mail software. How ever we use Exim instead.

In hostname I use real host cp1.site.com and real email.
I was warnings only:

[ * ] Configuring system settings…
Info: Cannot remount /proc (LXC containers require additional perm added to host apparmor profile)
[ * ] Configuring Hestia Control Panel…
[ * ] Generating default self-signed SSL certificate…
req: No value provided for Subject Attribute emailAddress, skipped
[ * ] Configure System IP…
cat: /usr/local/hestia/data/ips/ No such file or directory

LXC I understand, but what want ssl and cat ?

Also after install hestiacp I got to email:

Can’t connect to MySQL localhost
ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/run/mysqld/mysqld.sock’ (2)

After reinstalling I got

12:45:13 Web Added new web domain (Name: debian1.home).
12:43:12 Web Web domain configuration applied (Domain: debian1.home, Backend: php-fpm).
12:05:13 Cron Jobs Cron job added…
12:05:13 Web Added new web domain (Name: cp1.site.com.ua).
12:05:12 Web Web domain configuration applied (Domain: cp1.site.com.ua, Backend: php-fpm).

Why hestia add domain debian1.home? Because I open it as http://192.168…:8083/ ?

In server setting I see debian1 host, but when I install hestia I write host as cp1.site.com

Proxmox changes the hostname on reboot…

Also the hostname is used for an LE ssl certificate and we try to generate it from the start because we got tired from the complains from the users…

For the error cat: /usr/local/hestia/data/ips/ I don’t know made a lot of test installs but none of those where behind a nat.

As Jaap already mentioned, the /proc error has to do with hiding processes from other users. If you’re not able to remedy this error, HestiaCP won’t stop working but it won’t work to it’s full potential.

The easiest fix I’ve found is to enable security.nesting: "true" either on the lxc profile or container itself. I run LXD directly, so how to accomplish this is likely a bit different in Proxmox.

Here is a forum post that talks about the security implications of allowing nesting. Essentially, there are none unless you also have made the container privileged. (Which you shouldn’t 99% of the time)

What does security.nesting=true? - Linux Containers Forum