Hestia + Cloudflare - Mail Only

To say that I have been at this for a day or so would be a gross understatement. This is what I achieved so far. Let me preface what I am going to say with this:

I have been hosting one of my two domains in hMailserver on a Windows Server 2012 machine for a while now. I also use Cloudflare. Everything functions as expected. Send and Receive just fine.

I have a second domain as well and would like to host both domains in HestiaCP.

I setup an account over at Digital Ocean and installed an instance of Debian 10.x and HestiaCP.
Again, I configured Cloudflare for all DNS entries. At least I think that I have them all. So far, it appears that I can send but am not receiving.

By the way, I had to use SMTP2GO because my ISP blocks port 25. Your assistance will be greatly appreciated. Peter

1 Like

UPDATE: I managed to get my send / receive working. Roundcube webmail was working as wll until a short while ago. What I see now when visiting http://webmail.mydomain.com/ is what appears to be a vanilla landing page that says “We’re working on it!” I have no idea what may have changed.

Did you add webmail.mydomain.com as web domain?

Hello again @eris. Thanks ever so much for coming to me aid. Actually, I did not add webmail.mydomain.com. But, what I did do was to enable / install SSL (Lets Encrypt) and all is working as it expected. No issues accessing Roundcube.

By the way, should I be adding webmail.mydomain.com. Is it absolutely necessary?

No, not at all. This is a potential source of issue, in case you had created that domain by mistake. Infact it runs now with ssl enabled, leave it like it is :slight_smile:.

Thank you for chiming in @ScIT I forgot to mention that I also created an A record at Cloudflare for “webmail.mydomain.com” which points to my mailserver’s IP. Now all that is left to do is to add my second domain which will also point to the same IP as my first domain. Fingers crossed. Have yourself a great Sunday. Peter

1 Like