Hestia control in ip:8083 redirects to HTTPS

Somehow I accidentally changed some settings and now Hestia control panel which is in SERVER_IP:8083 redirects from http to https. As I know https works only for domain names. In my case the Hestia panel in is not in domain, it is in SERVER_IP:8083. So it tryies to open the site with HTTPS and it say :
This site can’t be reached
SERVER_IP took too long to respond.

https://ip:8083 should also work fine

If you login with ssh check if the hestia service is running

As I mentioned above as I know it is impossible to give ssh to IP address. https is now only for domain names. I don’t know any ip address where you can access with https.

Anyway, is there a way to change it to http in the server configurations through ssh access?

SSL access works fine you only have issues with getting a valid ssl certificate for it .

By default Hestia redirects http://ip:8083 to https://ip:8083 With a self signed certifiacate your still need to accept it…

Login with SSH to see if hestia service is running. Most likely it is offline

Sorry, I am new in Hestia. How to see the status of hestia or run Hestia in terminal

systemctl status hestia


It is active. How to disable https redirection for Hestia Control Panel with terminal

There is no need to disable ssl redirection. Do you have cloudflare in use? ssl works also on ip address, you’ll just get a insecure note.

My websites are working very well in that server which are also created by Hestia Control Panel. I just turned on ssl cert for my IP then it stopped to open the page. That is why I am asking if there a possibility to disbale it through terminal?

how exactly did you turned on ssl for your ip?

essentially no. the control panel is listening only on port 8083 and that is using ssl.
afaik it never ran on plain http, because you would not want to send your login credentials unencrypted.

as other already said you can however connect to the IP via https, you will get a warning in your browser, that the certificate can’t be verified, but you should be able to skip over that.

if your browser cannot connect to https://IP:8083 then something else is blocking that access and you might want to check, what exactly. could well be, that you have some firewall oder internet security appliance that is blocking here. or do you eventually (have to) use some proxy/vpn or the likes?

last thing to check would be, if you got your own (local) IP blocked in fail2ban for whatever reason and therefore are unable to connect.

there is actually nothing to do that… so yeah:

I don’t think that it is because of firewall becuase I have tried different VPN and with different devices. Nothing has changed:

Why I am asking to change to http is becuase before it worked fine. And now I need to change something as soon as possible.

Trying 185.209.30.99...
Connected to 185.209.30.99.
Escape character is '^]'.
^X^ZConnection closed by foreign host.
[email protected]:~# telnet 185.209.30.99 8083
Trying 185.209.30.99...

Port 8083 is not open or Hestia listens to a different port

1 Like

run a netstat -tulpn or similar to see the ports your server is listening on.

also regarding firewalls: did you do any changes to the iptables settings? check iptables -nL to see if port 8083 is allowed to listen publicly…

How to check in which port Hestia is working? Or how to open Port 8083?

telnet hostname.domain.tld 8083

if you get an answer, its open. We cant access your system, so i cant say whats wrong. Just can say that hestia is working out of the box on a hetzner vps, if you can reproduce the issue there, you’ll have my full attention.

Login in ssh:

And run:

netstat -tulpn

copyright by @falzo :slight_smile:

2 Likes

Probably its a firewall block.
Just access ssh and turn off firewall
v-stop-firewall

After, access panel and add rule

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.