Hestia CP & Oracle Free Tier no Internet Access

This is just for info as i see this type of thread comes up every so often.

I am testing Oracle Clouds free tier which is pretty decent for my dev sites, however after installing hestiacp via ssh, the login page would not connect at all, i tried different distros and even tried installing the Big P to see if it was a hestia issue.

Anyways cut a long story short, i could not access the webpage regardless of control panel, so starting doing some digging. And the solution makes sense but is not really documented anywhere

Steps are:

  1. Create your virtual network
  2. Create your instance and install Hestia
  3. Add your ingress rules to allow access to the ports you need

The above is well documented however on Ubuntu what is not mentioned is the following:

The firewall works on 2 levels, the Ingress rules you set on the oracle cloud panel and the Ubuntu Firewall rules which are controlled from the ingress rules. However you have to do the following to actually get the Ubuntu rules to flush and update:

sudo iptables -F

This will update the rules and the Hestia control panel is accesible

To survive after a reboot then after entering the above command use this command

sudo netfilter-persistent save

Anyways if this helps anyone avoid the hassle then job done

2 Likes

That video does not work with current images.

I did check that video to see if I had missed something.

If you follow that when you get to the point of accessing the panel foe the first time after adding ingress rules you will get unable to connect error message.

Only after entering the above commands is the page finally reachable.

This applies on the ampere shape and any of the ubuntu images from 20 04 and up including full and minimal images

Ubuntu 22.04 has been released but it should still work…

you are awesome, thanks. :love_letter:

1 Like

Here’s Oracle Cloud’s document to get the ports you need open well, opened.