Hestia CP sets the wrong IP

When installing Hestia CP, it sets the internal IP to 192.168… instead of the external IP. Therefore, the system does not work.
How can I fix this error so that Hestia understands the correct IP address? Thank you.

Run v-list-sys-ips as it should list all the available ips it knows…

And why?
/usr/local/hestia/func/main.sh: line 1548: /usr/local/hestia/conf/hestia.conf: Permission denied
ls: cannot open directory ‘/usr/local/hestia/data/ips/’: Permission denied

Run as root or with sudo

It’s horrible, you can’t even delete the panel, you only have to demolish the system. Considering that I’m 3000 kilometers away from the server, Heastia CP developers are horrible people.

There is no need to be so rude about it.

It’s a free panel.

Just rebuild the server/install OS or revert to backup if you have. What distance from server has to do with anything ?You don’t have to manually install linux from a usb or cd. Are you installing it own your home server?


Thank you.

Yes we don’t supply an deinstaller as Hestia install other software and restoring to original settings takes more work then clean in install

So what… Please use one of the 100 other control panels…

… And you don’t have a ipmi or remote management interface, beside that - cpanel is also not uninstallable, so probaly cpanel devs are horrible aswell :man_shrugging:.

Anyway, have fun, but somewhere else :+1: :door:

for everyone else:

of course HestiaCP can be uninstalled completly. it’s a debian package after all, just use apt and your sysadmin skills.

also might want to use --purge to get rid of the config files as well as check the install script for any packages that get installed like apache/nginx/mariadb/php and so on.