Hestia is working, but cannot get SSL to work

I have a self hosted server in my office running Ubuntu 22.04. I have installed Hestia on it, and it works when logging in, and after getting a DNS and website set up on a user account I keep getting snagged on getting SSL verification to work. I have looked through the documentation and other areas of the internet to troubleshoot what is happening and what to do differently to make the install function. No solution has come after some time working on this.

I’m someone who isn’t IT, but I’m an electrical engineering student and this stuff isn’t a foreign concept. This is the one thing that I have been trying to figure out and any thoughts you guys have would be helpful. This project has been going on for 2 months and I’ve even tried configuring everything manually to see if that would help getting SSL to work.

Thanks.

To give more context with the SSL issue:

  • I have tried using the Let’s Encrypt option given in the panel.
  • I have goDaddy SSL verification since my domain name is from them.

neither have worked after spending time on if either would be helpful.

Is the site accessible from the public internet? If you want to use the built-in tooling to obtain automated certificates from Let’s Encrypt, your site needs to be able to satisfy an HTTP-01 challenge which is why the site needs to be accessible from the internet.

You can enter your site hostname into Let’s Debug to get more diagnostic information to help you understand what isn’t working.

https://letsdebug.net/

1 Like

that definitely helped me to see it has been accessible. Also, I was digging into the domain stuff and it turns out I was missing on checking the “redirect through the https” so I was overthinking and digging more than I should have.

1 Like