Hestia not recoginzing the Cloudflare's Origin Certificate

I have installed the SSL origin certificate and even changed the ssl certificate in both the domain and under the server’s setting. And my cloudflare status is set to strict mode. I have tried on full mode but still showing the let’s encrypt certificate. Hestia CP and all my website in hestia are showing Let’s encrypt certificate. I have wasted my whole day figuring out what the hell is wrong with. I have used hestia before and you just had to paste the Cloudflare’s certificate and everything works fine. I don’t want to use Let’s ecnrypt because i create problems and sometimes show ssl errors to visitors.

Edit: I copy/pasted the CF’s origin certificate in the Configure Server’s setting and it shows setting save sucesfully, but when i go to setting it shows empty. Does the problem is here ?

Screenshot 2023-01-07 at 11-04-15 SERVER - hcp.seeoldnyc.com 2083 - Hestia Control Panel

Should i replace the ssl setting in the some hestia.conf file ?

Update the hostname.domain.com in the web domain setting and then use

v-update-host-certificate admin example.com

I’m sory i’m uanble to understand. Where do i update the domain name in web domain setting ? I have already updated the subdomain where i’ve installed the hestia with oracle ssl certificate. And it is showing.

Run then:

v-update-host-certificate admin hostname.domain.com via ssl it should update then.

Just ran the command and it is stil showing let’s encrypt certificate both on Cpannel and main domain.

Then the main domain has still the lets encrypt active. Disable SSL save. Enable it again and add your SSL to it and then run v-update-host-certificate again

I disabled the ssl from domain and subdomain where i installed hestia. Re-enabled it added the certificate saved the setting. Ran the command v-update-host-certificate admin subdomain.domain.com via ssl. Rebooted the hestia, rebooted the main server, cleared everything. And still seeing Let’s encrypt.

Even the certificate files /usr/local/hestia/ssl are showing cloudflare’s certificate. And Nginx.conf file is pointing to these files. But the dman let’s encrypt ceritifcate is showing.

Restart hestia service

I restart hestia everytime.
Now i have tried another solution, created a directory and put the cloudflare certificate files inside it, changed the navgination to that directory in nginx.conf and it is still showing the dman let’s ecnrypt certificate. Where is the exactly let’s encrypt certificate?

So there is a problem/bug with Hestia. I added another website in Cpannel and installed another ssl and rebooted everything. That domain was also showing Let’s encrypt ssl certificate. I added 3 website and again no difference.

I created another server and installed hesta and before rebooting. I added Cloudflare ssl and updated host. Still on freshly installed hestia the same problem, it is using Let’s encrypt. I searched on this forum and i’m not alone, many people are facing the same issue.


And it should work fine if the primary hostname is working with this method

v-update-host-certificate admin domain.com and it should work

Have done this method multiple of times…

Yes i followed this tutorial. And ran the comamnd multiple times that you are suggesting. But none of this worked that’s why i posted the question here.

The primary hostname have by default let’s encrypt.

I have used hestia before and everything worked fine. I just pasted the certificate in Settings > Configure > SSL and that’s it now the ssl option gives success mesage but the ssl certificate page shows empty.

If you are seeing Let’s Encrypt certificates when traffic is routed through Cloudflare, you may be seeing the edge certificate. Let’s Encrypt us one of the Certificate Authorities that Cloudflare uses.