Hestia + roundcube + managesieve = Unable to connect to server

Hi guys!
On my server I have hestia under ubuntu (the latest versions), I have roundcube, it already has the managesieve plugin built in, I include it in the roundcube config, then in the managesieve config I write in this line $config[‘managesieve_host’] = ‘localhost’; instead of “localhost” the IP of my server, but every time I log into the roundcube web interface and go to “filters” I get “Unable to connect to server.” What am I doing wrong?
At the same time, everything else works! I’m bad at this kind of setup, so I’m asking for a detailed answer! Thank you!

Why are you trying to change localhost to the server ip? Also, that config option should include the port:

$config["managesieve_host"] = "localhost:4190";

Double check that sieve (dovecot) is listening on port 4190:

lsof -Pn +c0 -i:4190 -sTCP:LISTEN

Port 4190 is open, $config[“managesieve_host”] = “localhost:4190”;, registered, but the problem persists.

1 Like

Show the output of these commands:

dpkg -l --no-pager "roundcube*"
lsof -Pn +c0 -i:4190 -sTCP:LISTEN
ls -la /etc/roundcube
find /etc -iname "*sieve*"
grep sieve /etc/roundcube/config.inc.php
grep -vE '^$|^\/' /etc/roundcube/plugins/managesieve/config.inc.php
grep -vE '^$|^\s*#' /etc/dovecot/sieve/20-managesieve.conf
root@hostname:~# dpkg -l --no-pager "roundcube*"
dpkg-query: no packages found matching roundcube*
root@hostname:~# lsof -Pn +c0 -i:4190 -sTCP:LISTEN
root@hostname:~# ls -la /etc/roundcube
total 84
drwxr-x--x   3 root www-data  4096 Feb 14 10:31 .
drwxr-xr-x 110 root root      4096 Feb 20 12:05 ..
-rw-r--r--   1 root www-data  3764 Feb 20 11:43 config.inc.php
-rwxr-x--x   1 root www-data 64583 Feb  2 12:36 defaults.inc.php
-rwxr-x--x   1 root www-data  2760 Feb  2 12:36 mimetypes.php
drwxr-x--x   5 root www-data  4096 Feb 16 14:08 plugins
root@hostname:~# find /etc -iname "*sieve*"
root@hostname:~# grep sieve /etc/roundcube/config.inc.php
$config["plugins"] = ["archive", "password", "newmail_notifier", "zipdownload", "managesieve"];
root@hostname:~# grep -vE '^$|^\/' /etc/roundcube/plugins/managesieve/config.inc.php
grep: /etc/roundcube/plugins/managesieve/config.inc.php: No such file or directory
root@hostname:~# grep -vE '^$|^\s*#' /etc/dovecot/sieve/20-managesieve.conf
protocols = $protocols sieve
service managesieve-login {
  inet_listener sieve {
    port = 4190
protocol sieve {
  managesieve_max_line_length = 65536
  managesieve_implementation_string = Dovecot Pigeonhole

Seems sieve is not installed on your server. Did you install Hestia with option --sieve yes?

Execute this command:

dpkg -l --no-pager "*sieve*"

If you can’t see two packages installed (dovecot-managesieved and dovecot-sieve) then you didn’t install it and you must install it manually.

To install sieve execute this command:


Problem solved, thanks! It turned out that sieve support was turned off!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.