HestiaCP 1.3 freezes on adding firewall rule

Tried to install Hestia on Debian 10. All was ok. All was running super fast! But when I added rule ‘Allow TCP 3306’ Hestia slowed down. One page was opening about 2 minutes or more. Ok, I thought, Debian is not good for Hestia and installed Ubuntu 20. Turned off iptables service in /list/server/ and added same rule which was added in Debian. All is ok, Hestia is not freezing! But do you remember I said that turned off iptables before adding firewall rule? Yes, after enabling iptables service Hestia began to freese again like it was in Debian. Pages of Hestia again was opening more than 2 minutes. While waiting for Hestia I tried to open my website which i uploaded earlier - it is opened in 10 sec 12 ms. I’ve reloaded my website and again it opened in 10 sec 11 ms. I tried again and it opened in 10 sec 13 ms. Magic, isn’t it? How can website be opened with such freezing and total difference in 1 ms? And why when Hestia’s pages freeze for 2 minutes, website freezes for 10 seconds? I couldn’t understand. But when Hestia’s page unfreezed, I’ve checked iptables service and turned it off. After 2 minutes Hestia stopped to freeze and came back to original state. My website started to open in 50ms. Please, can somebody explain, what it was? Does Hestia ready for production or it is only for testing and playing purposes?

For sure hestia is ready for production, a lot of users uses it that way :slight_smile:.

Without further debugging and analyzing I can’t tell you what’s wrong with your system. What I just can say, because you provided this information, is, that is probaly not what you want. The cidr you have given there, allows the range from to If you really want to make the mysql service reachable from everywhere, please use

For the performance issues, please check your system load, log informations, etc. Does it also occure on a non sql domain? Is the backend running smooth (different services)? Just to throw out a few first questions :slight_smile:.