HestiaCP Admin Dashboard SSL Privacy Error in Chrome

As the title says, I’m getting the error ONLY in Chrome.

  • Privacy Error
  • NET::ERR_CERT_AUTHORITY_INVALID
  • Certificate (Invalid)

Further Details:

I’m using Letsencrypt certificate for the HestiaCP admin dashboard on another port number, not the default one.

SSL works on Firefox, Brave, and Google Chrome INCOGNITO mode. BUT not in the normal Chrome session. I’ve resetted the browser settings to original and restarted the browser a few times and also my machine. Had checked date is correct and SSL certificate is not expired.

Any idea on how to troubleshoot the issue?

Can I just ignore this error and move on? Since the certificate is fine when tested on 3rd-party ssl tester app like ssllabs.com.

Hi, infact it’s working on chrome on incognito mode, please clear your cache and try again. Sounds like it’s a caching issue.

It’s not browser cache, like I said above - I cleard all the cache and even resetted the settings back to original.

The problem was, something to do with the certificate chain.

https://www.sslshopper.com/ssl-checker.html ssl checker was able to help me pin point the problem, since it has a feature to scan custom ports.

So I scan vps.mydomain.com:port and the app mentioned about certificate chain. And so I poke around and explored all the certificate files inside /home/admin/conf/web/vps.mydomain.com/ssl/.

I used the .pem file, instead of the .crt file and created a symbolic link pointing to it from /usr/local/hestia/ssl/certificate.crt.

Then I restarted hestia, apache and nginx to make sure the changes were applied. I then tested the setup and bam! It worked, no more error in Chrome.

Ah, I would suggest you to checkout the command v-add-letsencrypt-host, this will do all the job automatically for you and configure all services properly.

1 Like