HestiaCP timeout

I have a v1.8.11 installation that works very well (Ubuntu 22.04 (aarch64)) -

except that if I open an SSH session it will close after a few minutes. Also, when I am in File Manager it also times out (back to login) after a few minutes.

A little frustrating.
Has this happened to anyone else?

I know there is an SSH parameter I use (ServerAliveInterval=3000) but that seems to be ignored.

Any ideas please?

In your /.ssh/config file enter:

Host *
 ServerAliveInterval 15

Thank you! Sorry no luck.

client_loop: send disconnect: Broken pipe - after 5 minutes.

and yes, I did restart sshd, even rebooted.

Try to expand the ClientAliveInterval seconds in /etc/ssh/sshd_config

You didn’t say what is the client you are using to connect to your server via ssh. @themew already gave a clue but you must use it in your client side, not in Hestia Server.

As I said, it will depend on the ssh client used but in my case this works perfectly from a client on a Linux OS.

In your ssh client config file ~/.ssh/config :

Host *
ServerAliveInterval 20
TCPKeepAlive no

TCPKeepAlive set to no is really important.

You could also try to raise ServerAliveCountMax to something like 30 (default is 3).

Host *
ServerAliveInterval 20
ServerAliveCountMax 30
TCPKeepAlive no

File Manager uses default php conf session.gc_maxlifetime and in Hestia it is configured to be 1440 seconds (24 minutes).

But as you said you are back to login, seems you are reaching Hestia Web UI session timeout that by default is 60 minutes (you can modify it in Hestia’s settings).

1 Like

Thank you sahsanu.
Clearly I have been ignorant (seriously) to the difference between client and server settings. My client end is MacOS (Darwin Kernel Version 23.2.0: Wed Nov 15 21:54:10 PST 2023; root:xnu-10002.61.3~2/RELEASE_X86_64 x86_64) and my server is Ubuntu 22.04.
I have applied your recommended client settings and trying them out now.

Thanks to all that have contributed.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.