How to allow mail acconts with tag?

Hello,

I want to use our mail accounts with tags. What I mean if you add + sign with tag name it forwards that mail to the main account. For example, there is an account named [email protected], when you send an email [email protected] or [email protected] or anything, it will forward this email to [email protected]
This option is available in Gmail, Outlook and other mail servers. How can I achieve it in Hestiacp?

This feature currently doesnt exist in hestia and is also not planed to develop.

Exim can actually do this. Take a look at setting these values in your config (and research before you act)

local_part_suffix = +*
local_part_suffix_optional

Note that editing your exim config is something you do at your own risk. If you break your server, then you can’t really expect people in this forum to help you out as you’re running a non-standard configuration. But if you accept that responsibility, then tinker away …

Update: I had a few minutes to test this out. The lines go in the “Routers” section of your exim config, under the localuser: router. That worked for my test. You may need to add them to other sections.

Troubleshooting tip: You can test routing with ‘exim -bt [email protected]’ which will tell you the router it used to deliver the message.

1 Like

If we tested this a bit more… Would it be worth considering submitting a PR?

As it seems surprisingly easy to accomplish.

If that is the case I can try with my production server to see if everything works fine and if that is the case, then proceed with a PR.

I understand that maybe it is not worth the risk for @ScIT and the team.

But would everyone want it? I don’t think we could assume everyone would. Are there any negative effects to enabling it? Perhaps more spam? Maybe security issues?
Just thinking out loud. But if exim has it disabled by default, there may be a reason for it.

I think I’d vote for leaving it how it is, but maybe write an addition to the documentation on how it can be implemented.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.