How to assign domain to host hestiacp

Best regard.

In the server configuration, basic options I have assigned the subdomain panel.dominio.com and although it is assigned it does not direct to the host of hestiacp.

How can I make this configuration?

Thank´s

Hi

You need one A record named panel pointing to the panel ip and Add this subdomain how new domain.
Should be direct to the panel. For install ssl in console: v-add-letsencrypt-host

Thanks for your support

  1. I have created an A record on Cloudflare panel.domain.com.
  2. in the hestia panel, settings, basic information assigned as the name of the server panel.domain.com.
  3. When I run v-add-letsencrypt-host, a new web domain panel.domain.com is created and that’s where the A record points, finally it doesn’t point to the hestia panel

I really don’t know what the error is or how to correct it

Disable proxy for http://panel.domain.com/

Thanks for your contribution, in effect the cloudflare proxy server for panel.domain.com is disabled, but it still does not address the hestiacp host.

I do not know if it is necessary to do some manual configuration in bind, maybe someone in the forum could expand this information.

I still continue without being able to assign a subdomain to the hestiacp host, I have not found how to solve it, I would appreciate if someone else can contribute to reach the solution

Thanks

Finally come to the solution:

  1. Create the zone dns to the ip of the server
  2. Go to configurations - configure - basic options, there we configure the sub domain that will point to the hestia panel, do not forget to save.
  3. we generate the ssl certificate for the hosto with the following command
    sudo / usr / local / hestia / bin / v-add-letsencrypt-host
  4. important if your dns zone is created in cloudflare it is necessary to disable the proxy server
  5. enter the panel.domain.com:8083

Thanks for the contributions and I hope this helps other people who have the problem

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.