How to create a directory in root domain folder

Hello, i am trying to install Open Source Social Network software on my Hestia and it requires there to be a data folder outside public_html for it to work. I have tried both the file explorer and ftp and nothing works and I am afraid to use SSH without knowing exactly what I need to do to make it happen.

Thank you for your time and patience. I am not exactly good at this. :slight_smile:

Enter via SSH as root
To create the directory:
mkdir /home/username/web/domain.tld/this-directory-is-what-i-want

Then, since you created that directory as root, you have to change the ownership.

chown username:username /home/username/web/domain.tld/this-directory-is-what-i-want

You can’t harm your system by creating a directory. The worst case scenario is that you won’t use it.

But you can make your website unusable if you change to the incorrect ownership. The command as is will not harm your system though.

Create in public html a folder called public and use doc root feature to change the docroot for the public site to /public/

is this the username of the Hesita domain owner or the vps?

Edit, now it says its not editable or writeable, I changed it to the username of my Hestia account, the vps account and even back to root. Nothing.

im trying to create the folder outside of public_html, not within it.

If you set the docroot to:

It works fine. This can be done with a custom template or the doc root feature explained in above.

It also solves any php execution issues you might have…

Templates? Docroot? php executions? Where do I find this? How would I modify it?

I’m really REALLY basic when it comes to how things work. I will probably understand if I’m given a rundown on how to do this but its pretty vague to me and more times than not, ill give up/skip something if I either don’t know how or its not explained to me how its done.

Not to be an ass (its gonna come off as assholeish though, i already know), but the same can be said for answer format as question format. Explaining what you need help with exactly should be met with how to, exactly, fix the issue.

Sorry if I wasn’t clear enough in my question but is there anything you need to know to help me if I personally wasn’t clear enough?

Thanks. :slight_smile:

SOOOOOO i ended up finding it and broke my install by adding “public” to the docroot. Took it off and it works now. Not exactly sure where to go from here.

I do, however, have a ossn_data folder outside my public_html but its still not writeable? Referencing again the Chown issue i was facing.

Figured it out. Pointed the software to domain.tld/private/ossn_data/ (created it before, obviously) and it works now. Thanks everyone for helping me. I appreciate all of the input.

1 Like

I’m happy to read that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.