How to enable http2?

hi
i’ve tried to activate http2, in 000-default-le-ssl.conf
(this file is created after running /usr/local/hestia/bin/v-add-letsencrypt-host)

i’ve added:
Protocols h2 h2c http/1.1

and modified
SetHandler "proxy:unix:/var/run/php/php8.1-fpm-MYDOMAIN.COM.sock|fcgi://localhost/"
as php8.1-fpm.sock doesn’t exist in my repertories

in the inspector of my browser, protocol is h3, not h2 as i was expecting …
does any one has knowledge in this matter?

on ubuntu 22.04 / cloudflare
thanks :))

my 000-default-le-ssl.conf:

<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerAdmin [email protected]
        DocumentRoot /home/USER/web/DOMAIN.NAM/public_html/nextcloud
<IfModule mod_headers.c>
        Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
        </IfModule>
<Directory /home/USER/web/DOMAIN.NAM/public_html/nextcloud>
          Options Indexes FollowSymLinks
          AllowOverride All
          Require all granted
        </Directory>
<FilesMatch ".php$">
         SetHandler "proxy:unix:/var/run/php/php8.1-fpm-DOMAIN.NAM.sock|fcgi://localhost/"
        </FilesMatch>
#LogLevel info ssl:warn
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

is not loaded in nginx.conf and so far I know it should also not created.

As your are using Cloudflare it will overwrite his own headers with Hestia headers …

where should i pu these tweaks then?
so far http2 is active, isn’t based on those settings?

Contact Cloudflare …

But default Hestia has allready https2 enabled:

Also Hestia that is on Cloudflare:

1 Like

all right! thanks
does it mean all my domains will benefit from hestia’s https2?