How to Enable SFTP Connection for User Account

Hi Everyone

Is there an explicit way to enable SFTP to users to allow them to connect securely? The current protocol for a user account is through FTP and then FileZilla prompts with a few SSL server options to select. Any Ideas will be appreciated…

Hello @Hussein

did you enable ftb connection for that account before try connect ? is port open too ?

For the default “user” you should be just able to select sftp in FileZilla settings

Yes, I opened 22, 21 and 12000-12100 in my Oracle account, but still I am unable to connect to the server.

I installed Discourse with Nginx template you added to the group, so I think the root cause of issue comes from this part.

I tried to select SFTP, but still I am unable to connect to the server, the error is

Status: Using username Hussein.
Error: Could not connect to server

Ports 21, 22 and 12000-12100 are open. The only way I can connect to the serve is by insecure FTP, which is not recommended.

One last thing, I just tried to upload a folder using FTP protocol with Use Explicit FTP Over TLS If Available encryption. It seems the process starts smoothly with (status: Server sent passive reply with unrouteable address. Using server address instead in FileZilla). The error in the post came when I’d tried to upload ZIP file, so I am wondering if Hestia FM supports zip files and extraction feature. However, still unclear to me why I couldn’t use SFTP directly at port 22?

Note: I see this error, but I am not sure how to fix it. After very lengthy timing of process, I haven’t found a guidance for this issue

Jul  6 21:08:51 talk sshd[5672]: Connection closed by authenticating user Hussein port 52571 [preauth]
Jul  6 21:08:58 talk sshd[5680]: Connection closed by authenticating user Hussein port 52572 [preauth]

If I use the root username and the ssh private key, it works find otherwise rejected.

I found the solution I put the domain name in the host name and set the Active Mode in FileZilla.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.