How to Unlock Queries Per Second QPS - FIXED RESOLVED?

I am fighting since 4 days non-stop trying to unlock its queries per second limited to 200.
I already checked every single thread on the internet and I just can’t unlimit it.

Already set into those files:

This settings:

IfModule mpm_event_module>
ServerLimit 2000
StartServers 12
MinSpareThreads 75
MaxSpareThreads 250
ThreadLimit 64
ThreadsPerChild 32
MaxClients 8000
MaxRequestWorkers 2000
MaxRequestsPerChild 10000

I also est into:

The value: worker_connections 4000;

And finally on:
/etc/mysql/mariadb.conf.d/all .cnf files

I correctly set:

This is just killing me, as on Directadmin I could unlock those queries from httpd in seconds.

What server hardware?

I have no issues with on my own server…


The same hardware than with my other VPS on Directadmin

Intel Xeon-E 2386G - 12 cores - 4.7 GHz
16Gb RAM ECC 3200 MHz

A Beast.

Working under Proxmox on CPU type HOST (not virtualized)

The problem is not on the server but on a setting somewhere that is blocking that number of requests.

On Directadmin I just edited the httpd file and I got 6700 queries/s. Same server.

Just Directadmin runs on Cloudlinux and Hestia on Debian.

That’s what is killing me.


Reached it, I share with you in case you face in the future that pain in the ass.
Never use value 1 nor 3 for innodb_flush_log_at_trx_commit.
Value 0 is more dangerous than 2, but it’s a price to pay to pass from a bike to a Ferrari on performance.

1 Like