I can no longer login via RDP

Hi team,

As the title says - I did a fresh install of Ubuntu 22.04 and was able to RDP no problem. Did the Ubuntu updates, rebooted, able to RDP still no problem

I then followed the install instructions (Getting Started | Hestia Control Panel) and rebooted. I can no longer RDP to my system. All settings for remote desktop are the same.

Any idea what I can do to resolve this?

Thank you

Hi @TheMidnighter,

Did you add a rule to firewall to allow RDP connections (port 3389) to your server?

I did not initially, I have not since.
I will try that and report back.
(To be clear: RDP worked before the Hestia install)

Hestia installs and uses iptables as firewall and adds rules to deny all traffic but allowed ports… and 3389 is not one of them.

You can add the rules via command line:

v-add-firewall-rule ACCEPT 3389 TCP "RDP_TCP"
v-add-firewall-rule ACCEPT 3389 UDP "RDP_UDP"

That makes sense. I added 3389 to ufw and that did not work.

I tried your commands, I get the error:

sudo v-add-firewall-rule ACCEPT 3389 TCP "RDP_TCP"
sudo: v-add-firewall-rule: command not found

If you are using sudo, you must add the full path:

sudo /usr/local/hestia/bin/v-add-firewall-rule ACCEPT 3389 TCP "RDP_TCP"
sudo /usr/local/hestia/bin/v-add-firewall-rule ACCEPT 3389 UDP "RDP_UDP"

You sir, are my hero of the day.
I had to do a reboot after that, and it worked!

Thank you

1 Like

You are welcome.

Just a tip, disable ufw, you should not have two apps adding firewall rules.

1 Like

Default user is admin but no default password, if you didn’t add the option --password when you installed Hestia then, Hestia installer generated a pass during install and you should have copied it :wink:

Anyway, change the password, it will be faster:

sudo /usr/local/hestia/bin/v-change-user-password admin 'HereYourNewPassword'
1 Like