I cannot change apache2 template


I’m a new user
I installed hestiacp with debian 9, apache + nginx + multiphp

I cannot change the apache template. it is always default…

How I can solve it


Go to /usr/local/hestia/data/templates/web/apache2/php-fpm

The /usr/local/hestia/data/templates/web/apache2/ is only for non fpm setups

1 Like

the question is, what exactly are you looking for? :wink:

the old types like hosting and fcgi don’t exist anymore after the change to fpm and multiphp, because they were specific to the use of mod_php or fcgi.

you should see another selector directly below which allows the choice of php instead:


however, as @eris pointed out correctly, if you want to use or create your own apache templates, these have to go into /usr/local/hestia/data/templates/web/apache2/php-fpm (though this might sound a bit confusing ;-))

1 Like

Thank you for replies.

I understood everything.
I have a little issue with a module of “prestashop”. This issue depends from server settings ( the same website in localhost works very well) and I tried to change the server settings to solve my issue but without success.

what is it, that the module needs/wants? :wink:

I solve the issues. WHen I installed the module into prestahop it hasn’t installed all files… I copied all files from ftp and it now is working well.
Thanks for your help but I don’t need the modules. I have already all modules need for my ecommerce.

However hestia is a super web panel for web. Before I used vesta but now I prefer hestia.
It is the best free panel.


1 Like