I decided to change the domain, but it was broken

Good afternoon. I decided to change my mydomain.art to domain.com. I registered a new domain, transferred NS to Cloudflare, and then I was stuck. When I try to log in to the hcp panel through the .art domain, everything is fine, but when I try to log in through hcp.mydomain.com, cloudflare writes about an invalid SSL certificate (Invalid SSL certificate Error code 526), and in order to log in to this .com panel, you need to switch from Full (strict) to Flexible in cloudflare. How can I fix this problem? I also couldn’t find a guide on how to rename my old domain to a new one, so I registered it as allias (which is bad, because the old domain will be deactivated within a week, and I want to keep my WP site). Are there any best practices for my case?

Change your server hostname (as root):

v-change-sys-hostname hcp.vladarsplay.com

Once done, issue a certificate for the new hostname (also as root)::


Note: If that doesn’t work, maybe you should disable in Cloudflare the proxy for hcp.vladarsplay.com to be able to issue a Let’s Encrypt certificate.

I would first remove the alias vladarsplay.com and after that, from command line, as root:

v-change-web-domain-name Volodia vladarsplay.art vladarsplay.com yes

Keep in mind that this won’t change the wordpress configuration so you should learn how to do that.

Just in case, remember to create a backup before modifying your installation.

1 Like

I have successfully renamed the domain in the panel, but I get an error when running other commands. Also in cloudflare I disabled the proxy for recording a hcp, but it didn’t help

You should edit the package used by your user and raise the limit for web domains.

1 Like

I logged in to hcp from under the admin account, and my user is assigned a default with unlimited, but error are the same. I also noticed that in the WEB tab of the admin account there is still an address hcp.vladarsplay.art.

There is no need to try to change again the domain name, the only command you will need from now on is v-add-letsencrypt-host, said that:

v-add-letsencrypt-host is trying to issue a certificate for your new hostname but to do that it has to create a web domain for that hostname under user admin, well, user admin uses by default the system package that has a limit of one web domain and it already has hcp.vladarsplay.art so you have two options, remove web domain hcp.vladarsplay.art from admin user or change the package used by your admin user to another that allows more web domains. I suppose the better approach in your case is to remove hcp.vladarsplay.art and once done, execute command v-add-letsencrypt-host

1 Like

Okay, sorry about that. I set the right limit, and I also had to fix an error with the rights, and voila, everything works. Thank you for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.