I have issues using my domain on my cpanel

I am experiencing difficulty accessing boltarc.com on my server, despite having added it to the server.

To provide some context, my hostname is server.boltarc.com, and my nameservers are ns1.boltarc.com and ns2.boltarc.com.
While https://server.boltarc.com loads without issues, boltarc.com does not.
screenshot https://prnt.sc/MNbnYuUTb_3T
Dns screenshot https://prnt.sc/p4O-7i0xRRXz

[email protected]:/usr/local/hestia/data/ips# nslookup boltarc.com
;; Got SERVFAIL reply from 2a01:4ff:ff00::add:2, trying next server
;; Got SERVFAIL reply from 2a01:4ff:ff00::add:1, trying next server

** server can't find boltarc.com: SERVFAIL

[email protected]:/usr/local/hestia/data/ips# 

How did you set the domain at your domain register?

i used namecheap Screenshot by Lightshot

the subdomain is working but main domain is not

Not here:
[email protected]:/usr/local/hestia/data/ips# ping panel.boltarc.com

PING panel.boltarc.com.mydomain.nu (xxxx) 56(84) bytes of data.

Thank you for the provided domain name! As I can see, the ns1-2.boltarc.com personal DNS servers are successfully registered from our side, you can also check it in the publicly available Whois lookup - https://www.namecheap.com/domains/whois/result?domain=ns2.boltarc.com

However, it appears that the personal DNS servers themselves are not connected to any hosting server - Dig (DNS lookup)

In order to resolve the issue, please create the following A records for your nameservers from the side of your hosting service provider:

to fix the issue i replaced my nameserver with my server ip
and the page is loading fine

You need to add ns1.boltarc.com and ns2.boltarc.com to the DNS records

when i had that the boltarc.com doesn’t load but after replacing it with ip it loads
i dont know where the bug comes from

i tried to add it back to test it out again and this error came out
only the hostname domain have the issue others dont

You need to add 2 A records
Record: ns1
Type A
Ip or valu: ip adress of the server

And repeat for NS2

thats what am trying now to see if it works

it worked thanks