I have this error when accessing phpmyadmin

Existing configuration file (/etc/phpmyadmin/config.inc.php) is not readable.

Keep in mind that redis is not part of Hestia.

I don’t know what you want to do but usually you wouldn’t need to open port 6379 because you usually will connect to redis from localhost and those connections are by default accepted by firewall.

lsof -Pn -i:6379 -sTCP:LISTEN

systemctl status redis-server

And check redis log:


make sure to update:

bind -::1

To listen to public address

Also make sure to protect the redis server with username and password…


telnet IP 6379
Connecting To IP…Could not open connection to the host, on port 6379: Connect failed

no errors here:

I think Redis is correctly installed. I can access Redis with both Wordpress and Lavarel plugins.

But I can’t access phpmyadmin now. Is this related to redis installation? Should I reinstall phpmyadmin again?

I have just reinstalled hestia on a fresh vps. Debian 12. No user created, no additional software installed.

I still have the same error for phpmyadmin

And you will have the same error till the perms are fixed in a future release.

chown -R root:www-data /etc/phpmyadmin/
chown -R hestiamail:www-data /usr/share/phpmyadmin/tmp/

Thanks. It’s working now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.