IMAPS and SMTPS doesn't work on Windows 7 Outlook 2010

I’m probably having the same problem.

I just set up a brand new hestiaCP installation:

  • Hestia Control Panel v1.8.11
  • Operating System Debian 12.4 (x86_64)

I migrated a user from a working vestacp server, which worked fine, but was using Ubuntu 16, so needed an upgraded OS.

I’m using same static IP and same hostname as the vestacp server was using so everything should be the same.

On my windows 10 PC, using Outlook 2010, the email account that was working with vestacp, began working again with the new hestiaCP server after the migration, using IMAP, with SSL on port 993.

BUT, my windows 7 PC, with outlook 2010, that has the exact same settings will NOT connect to the hestiaCP server.

I set up another user account in hestiaCP to test and a different computer with a fresh install of windows 7 and outlook 2010 and I’m getting the same errors in outlook saying can not establish a secure connection using IMAP. SSL and port 993, so this must have to do with windows 7.

I was able to get IMAP to work on windows 7 outlook 2010 using no security protocol and port 143, BUT could not get SMTP to send using port 25, so I don’t even have a work around solution.

I really need to understand what is different for security on hestiaCP than my vestacp setup because this was a trial upgrade that I’m planning to do for about 100 other email accounts and I’m sure some of them will use windows 7 or something else that gives them errors, so I need to understand this before I move forward with HestiaCP.

Thanks in advance for any help or suggestions!

OK, I figured it out.

Turns out Windows 7 supports TLS version 1.1 and 1.2 BUT they are not turned on by default. I had always assumed that going to the “Advanced” tab of the “Internet Options” in the “Control panel” and ticking the boxes “Use TLS 1.1” and Use TLS 1.2" was enabling them, but I guess not.

I followed the instructions here:

Which told me:

To enable TLS 1.1. and TLS 1.2 on Windows 7 import the following registry keys:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]

As soon as I created the 4 registry keys above using regedit.exe Outlook 2010 worked fine with my HestiaCP Server.

Hope that helps someone else.

1 Like

Just as a side note: Win7 and Office2010 is out of support since a long time already, I would strongly suggest to switch to a newer system and office version as soon as you can - this is a decent security risk.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.