Installer error/problem: Nginx+PHP-FPM-Multi PHP

Hi!

I am switching from Vestacp to Hestia and had my troubles yesterday.
Originally I wanted to install these:

Nginx
PHP-FPM
Multi-PHP

But the installer didn’t want this combination. It ignored the PHP-FPM and installed normal PHP instead

Tried again, took out the Multi-PHP, than it confirmed the PHP-FPM. All fine, except the missing Multi PHP

Tried another route:
Apache
Nginx
PHP-FPM

Here it ignored the Nginx.

Am I doing something wrong?

bash hst-install.sh -n yes -w yes -o yes -v yes -k yes -t yes -c yes -x yes -z yes -b yes -i yes -m yes -l de \ -s domain.com -e @mail@mail.com -p PASSWD -a no -j no -g no -r 8083 -y yes -d yes*

I want the first route.

Thanks

URBANsUNITED

if you are using Ubuntu try this

sudo -s
sudo apt-get update && apt-get dist-upgrade && sudo apt-get upgrade
wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install.sh

sudo bash hst-install.sh -a no -n yes -w yes -o yes -v no -j yes -k yes -m yes -g no -x yes -z yes -c no -t no -i no -b no -q yes -d yes -f yes -y yes -r 8083 -s domain.com -e [email protected] -p somepassword -l en

This will install Nginx + PHP-FPM + Multi-PHP

Thanks for the answer.
But it’s the same command as I did, only in a different order.
It didn’t work…

Please use the long format when posting hst-install arguments, it’s faster for everyone to decode what you try to install.

For multi-php use only the multi-php flag ex:
--apache no --nginx yes --multiphp yes ..

I use these command to install :

wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install.sh

bash hst-install.sh --nginx yes --apache no --multiphp yes --named no --exim no

  • NGINX Web / Proxy Server
  • Multi-PHP Environment
  • MariaDB Database Server
  • Vsftpd FTP Server
  • Firewall (Iptables) + Fail2Ban Access Monitor

try this Added generated Advanced Instalation